Help with Log4OM and FlDigi

Regarding connecting to external program's.
Post Reply
m0lmk
New user
Posts: 2
Joined: 05 Mar 2017, 12:25

Help with Log4OM and FlDigi

Post by m0lmk » 05 Mar 2017, 12:29

I'm a new Log4OM user and I'm trying to get it working with FlDigi.

I have Log4OM working with my FT-857D via Omnirig but can't seem to get it to play nice with FlDigi. I have followed the manual (page 186) and looked at several youtube videos but it's just not working for me!

The "Comm Services" indicators are yellow and green (I understand they should both be green). Can anyone give me some pointers as to why it's not working?

I'm running windows 10 (which may be part of the problem)!

Thanks,

Matt
M0LMK

User avatar
G4POP
Moderator
Posts: 5159
Joined: 21 Jan 2013, 15:55
Location: Burnham on Crouch, Essex UK

Re: Help with Log4OM and FlDigi

Post by G4POP » 06 Mar 2017, 09:28

What exactly is not working?

Logging, frequency control or what?
73 Terry G4POP

User avatar
ac5ez
Novice Class
Posts: 15
Joined: 18 Jan 2017, 18:03
Location: Oak Point, TX USA

Re: Help with Log4OM and FlDigi

Post by ac5ez » 06 Mar 2017, 20:26

There are several things to check: (1) When you create a new logbook in FLdigi the file is stored in "C:->Users->XXX->fldigi.files/logs" where "XXX" is your user name. Creating a logbook is a two step process. First select New, then select save to create the new logbook. (2) In FLdigi go into "Configure->Rig Control and make sure RigCAT, Hamlib, Hardware PTT are all UN-CHECKED. XML-RPC CHECK Use XML-RPC program. Flrig shoud also be UN-CHECKED. FLdigi's logbook is acutally an *.ADI or an ADIF file. Log4OM monitors the file and everytime FLdigi posts and QSO Log4OM reads it and imports the data in its database.

Next open Log4OM Communicator. Click the Red button to stop the communicator. Go into settings->Inbound->FLdigi Interface. Check all boxes. Select the logbook you created in FLdigi above then save. Next press the green button on the communicator. Log4OM should now be monitoring the FLdigi logbook. If for some reason the TCP link does not start you will see "Comm Services" at the bottom of the Log4OM window. Click it and restart the TCP session.
Hope this helps.

m0lmk
New user
Posts: 2
Joined: 05 Mar 2017, 12:25

Re: Help with Log4OM and FlDigi

Post by m0lmk » 06 Mar 2017, 21:06

Thanks both.

I'm away for a few days so can't get to the machine but nothing was working. Logs saved in FlDigi were not showing up in Log4OM and the frequency was not changing in FlDigi when changed on the radio.

I followed the instructions (as documented and as provided by ac5ez here).

I'll take another look when I get back, run through the setupagain and report back here if I still have problems.

Thanks,

Matt
M0LMK

Post Reply