Page 1 of 1

Fldigi PTT issue

Posted: 09 Jan 2018, 18:25
by ha5uk
Hello all,

brand new to Log4OM and group, I have looked up in the forums and don't see an answer for my issue, but I might have missed.

Paired WSJTX/JTAlert and Fldigi with the logger. WSJTX works flawless right and back on every aspect.
Fldigi also works fine, except: no PTT action. Communicator seems ok, Freq shown and changes right, logging is also ok. Hit a line on cluster puts details into Fldigi. Nice response for ptt in the logger but nothing in Fldigi.
I have followed the manual (page 186), and launch Fldigi prior. Using omnirig, CAT com port generated by Microham MK2.
Fldigi Rig controll is XMl-RPC, all other is unchecked. Started everything again many times.

Any hint what to do to make ptt alive?

Re: Fldigi PTT issue

Posted: 10 Jan 2018, 11:11
by DF5WW
Hello OM,

don´t use a COM in Fldigi Settings. Only XML-RPC is required and PTT will be o.K. by Log4OM & Omnirig.
Have had some QSO´s with Fldigi last Monday and no PTT problem.

In my Radio settings only XML-RPC is enabled not any COM in Hardware PTT or Flrig, Hamlib or
others. All is disabled.

;) ;)

B.t.w. On my end Tune Button in latest Fldigi is not working but if i send a Macro or hit the TX button all
is working fine. Macros in Fldigi should be start with <TX> and end with <RX>

Re: Fldigi PTT issue

Posted: 10 Jan 2018, 12:06
by G4POP
DF5WW wrote:
10 Jan 2018, 11:11
B.t.w. On my end Tune Button in latest Fldigi is not working but if i send a Macro or hit the TX button all
is working fine. Macros in Fldigi should be start with <TX> and end with <RX>
Tune button is a known defficiency with FLDigi XML/RPC that FLDigi developers seem to be ignoring

Re: Fldigi PTT issue

Posted: 10 Jan 2018, 13:14
by DF5WW
Not a problem for me Terry, i can use TX Button ;) :D

Don´t have to tune anything so my automatted Tuner is working great and
i have a Tune button at the radio himself .. HI

;)

Re: Fldigi PTT issue

Posted: 10 Jan 2018, 15:09
by ha5uk
Thanks Juergen,

But as I wrote in Fldigi only XML-RPC is enabled others disabled - fallowed former tips. All working but ptt...brrr

73, George

Re: Fldigi PTT issue

Posted: 10 Jan 2018, 18:36
by DF5WW
Hi George,

your Modem gives you several virtual COM ports. What is the reason if you start Log4OM only and hit the PTT Button ?
Did PTT work in Log4OM or not ? If not try another COM of your Modem in Omnirig.

I don´t have a Microham i´m using a Digimaster Pro3 from ZLP Electronics and all is working fine here. I have also
different virtual COM´s buter after a bit testing i found the right one.

;) ;)

Re: Fldigi PTT issue

Posted: 10 Jan 2018, 23:39
by ha5uk
Juergen,
Com port that issued must be ok. That drives all ptt's except Fldigi.
Tried different ones - same result. Pushing the ptt in Log4om was only a test. Ptt info should be passed via XML RPC along with freq, logging etc...
Reinstalled Fldigi - nothing better. Weird.

Re: Fldigi PTT issue

Posted: 11 Jan 2018, 11:10
by DF5WW
Hmmm .... have you try to play a bit with different RTS/DTR Settings in Omnirig ?
Is latest Omnirig installed with administrator privileges and Log4OM too ?

Omnirig.png
Omnirig.png (5.34 KiB) Viewed 2527 times

Re: Fldigi PTT issue

Posted: 13 Jan 2018, 18:34
by ha5uk
Solved. Tried everything, going to extremes eventually updated the router in Microham MK2. No setup change at all. Before that everything was ok except Fldigi's ptt while thru Log4om. After this firmware update the PTT is ok, but other issue popped up: N1MM always quits with ext. error when FSK is set for Digi modes. Nonsens hihi.