Page 1 of 3

LOg4om and JT-alert

Posted: 06 Feb 2014, 21:39
by NS2R-Phil
Hi, Been trying to get log4om to receive qso data from jt-alert . No luck. I spent alot of time with Laurie the author of jt-alert. He can't figure out what's wrong!. I also tried to send qso data to LOG4OM from HRDlogbook, no luck. It seems UDP isn't working for me. I've been playing with this now for a few days and haven"t made any headway. Any suggestions? Everything was set up according to log4om help doc :( Tnx.....Phil NS2R

Re: LOg4om and JT-alert

Posted: 07 Feb 2014, 06:39
by G4POP
Phil,
Is the Log4om communicator running and minimised, you should have two Log4om icons on your windows task bar?

Have you enabled UDP in Log4om communicator and is it set to 2236?

Have you ensured that you do not have any malware of firewall stopping the UDP communication?

Are you running Log4om and it's communicator as an administrator?

Re: LOg4om and JT-alert

Posted: 07 Feb 2014, 08:30
by G4POP
Phil,
If you are testing using manual date entry in JT65 be aware that if you enter the date incorrectly although the QSO will be logged to Log4OM that it might not readily show in the recent QSO window - Try clicking the date title at the top or the date column in Log4OM a couple of times

This morning i have downloaded and installed JT65 HF and JTAlert and all works fine for rig control with Omnirig and logging.

I recall that you have had ongoing issues with running HRD and Log4OM at the same time with a VSP I wonder if your issue with JTAlert is connected in any way, seems like a local problem at your end?

Re: LOg4om and JT-alert

Posted: 07 Feb 2014, 11:28
by IW3HMH
Try starting Log4OM as administrator.
Sometimes windows prevents infra-application communications via networking due to security reasons.

Re: LOg4om and JT-alert

Posted: 07 Feb 2014, 18:15
by DF5WW
Did you have enabled in JT-Allert the logging to Log4OM ??? You will find it under the JT-Alert setup under logging. The checkbox "Enable Log4Om loggin" must be enabled and the UDP Port 2236 must be active with the IP 127.0.0.1. In the line below your IP and UDP the path to your Log4Om SQlite database must be set ;)

Have worked with JT65-HF and later with WSJT-X .... No problems with logging via JT-Alert

B.t.w. JT-Alert is a nice software from one of our Members ;) :!:

Re: LOg4om and JT-alert

Posted: 08 Feb 2014, 23:16
by NS2R-Phil
Tnx for all your suggestions. I went over everything more than 20 times, but no success. When I do a CMD netstat -a, it shows that UDP port 2236 is opened by the communicator, but can't get jtalert or hrdlog to send data to the sql database. I've been using jtalert jt65/jt9 for a few years with hrdlog without a hitch. Log4om is potentially far superior to hrdlog. I'll keep at . Tnx agn 73...Phil NS2R

Re: LOg4om and JT-alert

Posted: 09 Feb 2014, 08:21
by G4POP
Phil,
When you say "HRDLog" do you actually mean the HRD suite of programs and specifically DM780?

You see HRDLog is the web site run by Claudio! and his web site only receives QSO's from programs like Log4om it does not send out logging data.

Re: LOg4om and JT-alert

Posted: 09 Feb 2014, 18:01
by NS2R-Phil
Terry, I meant the HRD suite, but HRDlogbook(part of HRD suite) does have a qso forward option via UDP. There must be a conflict on my machine between log4om and an ongoing process running in the background. Thanks 73..Phil

Re: LOg4om and JT-alert

Posted: 09 Feb 2014, 18:32
by G4POP
NS2R-Phil wrote:Terry, I meant the HRD suite, but HRDlogbook(part of HRD suite) does have a qso forward option via UDP. There must be a conflict on my machine between log4om and an ongoing process running in the background. Thanks 73..Phil
Actually it's the DM780 part of the HRD suite that forwards by UDP the HRD Logbook entries, are you certain that you have enabled this in the DM780 menu and the settings in DM780 are set to localhost and port 2236?

If you do have that set correctly then my best guess is that something is blocking the UDP transfer like malware, anti virus or firewalls

Re: LOg4om and JT-alert

Posted: 09 Feb 2014, 22:06
by NS2R-Phil
Terry, If I simply want to use JT-alert with WSJTX and log4om, will that work? What I rally want to do is forward the log data from wsjtx through jt-alert to log4om. Does DM780 have to be in the picture? tnx...Phil