"Update on import" ADIF to fix WSJT-X 1.9.1 TX_PWR bug?

Your ideas for making Log4OM even better.
Post Reply
DK9SAS
New user
Posts: 2
Joined: 26 Aug 2018, 13:53

"Update on import" ADIF to fix WSJT-X 1.9.1 TX_PWR bug?

Post by DK9SAS » 26 Aug 2018, 14:51

Hi there,

I just wrote a bug report at https://groups.yahoo.com/neo/groups/wsjtgroup because WSJT-X exports the field TX_PWR in it's ADIF in a slightly incorrect way (there's the letter 'W' appended where there should be only a number, that's against ADIF standard.).

I saved my ADIFs and have a SQLite Log4OM database file, so I wrote a little python script to update the TX_PWR field in the Log4OM database directly from the already imported ADIF (see here: https://gist.github.com/RipperFox/0f2fd ... d90d5953dd).

So I was able to fix my QSOs logged in WSJT-X this way - but other's might not have the knowledge/time to fix their stuff - so it might however be possible to add a "update" feature to the ADIF import?

73, Sascha DK9SAS

DK9SAS
New user
Posts: 2
Joined: 26 Aug 2018, 13:53

Re: "Update on import" ADIF to fix WSJT-X 1.9.1 TX_PWR bug?

Post by DK9SAS » 26 Aug 2018, 17:00

Seems the fault ist mostly on my side PEBCAK - I seem to have entered the letter "W" there somwhere in the past - but the ADIF export function shouldn't try to stuff all the garbage the user entered into a field reserved for numbers anyway - maybe someone adds a check :)

73, Sascha

N6VH
Advanced Class
Posts: 44
Joined: 07 Nov 2015, 16:41

Re: "Update on import" ADIF to fix WSJT-X 1.9.1 TX_PWR bug?

Post by N6VH » 26 Aug 2018, 21:46

I sent a reply to your message on the WSJT-X list. Hope you saw it. I just want to emphasize that using JTAlert provides many features, including logging to Log4OM, without having to import an ADIF.

I did a test, importing an ADIF with "100W" in the tx_pwr field. In that case, Log4OM recorded the power as 0. However, when using JTAlert to log, the power is correct in Log4OM.

73,

Jim N6VH

Post Reply