USA-CA award Not Found errors

Moderator: OE6CLD

User avatar
G4POP
Moderator
Posts: 5813
Joined: 21 Jan 2013, 14:55
Location: Burnham on Crouch, Essex UK

Re: USA-CA award Not Found errors

Post by G4POP » 09 Jul 2015, 14:03

No problem, anytime.
73 Terry G4POP

w9nwrwi
Novice Class
Posts: 22
Joined: 25 May 2015, 15:42

Re: USA-CA award Not Found errors

Post by w9nwrwi » 20 Jul 2015, 20:06

For the past few weeks I have been on and off trying to get my USA-CA Not Found Errors corrected. I cannot seem to get the program to hold my changes.
As an an example I have logged an Alabama county as Saint Clair, this is incorrect. I check the Log4om Utilities/Awards Manager/Award References and find that ST.CLAIR is the correct syntax for Log4om.
I open the QSO to edit and change the county to ST.CLAIR, select Update and then Save And Exit. The Update of the QSO saves the change but USA-CA under Statistics and Awards does not reflect the change, i.e. it still appears in the Not Found list with the wrong syntax.

What the heck am I doing wrong? Anyone else happen to have a ST.Clair county that is listed correctly? It is just one of 75 that I must change.


Thanks,
Chuck

User avatar
KA1WPM
Advanced Class
Posts: 31
Joined: 05 May 2015, 14:57
Location: Winsted, CT, USA

Re: USA-CA award Not Found errors

Post by KA1WPM » 07 Aug 2015, 13:23

Hi Chuck,

I don't know if you got your problem resolved. I just started doing these counties myself and have come across the same problems. One thing that I noticed is that you also have to remove the incorrectly populated award reference from the awards tab in the Update QSO dialog in addition to adding the correct one. So if you add USA-CA@FL-ST.LUCIE to the Awards Program on the Awards tab, you also have to get rid of the "USA-CA@FL-SAINT LUCIE" that was probably created by the SQL query. Also, after updating the QSO hitting refresh isn't enough to make the NOT FOUND go away. Clicking "Open" for the award again makes everything right, provided that you don't have more entries like this.

I'm no expert in SQL, but these are the things that I observed over the last couple of days. I hope it is useful information.

73,
-- Dana, KA1WPM
-- Dana, KA1WPM

w9nwrwi
Novice Class
Posts: 22
Joined: 25 May 2015, 15:42

Re: USA-CA award Not Found errors

Post by w9nwrwi » 07 Aug 2015, 18:58

Thanks for the reply Dana,
I still have the trouble and will double check using your procedure. Admittedly I kinda gave up on it as there was no action to my trouble.
Since both of us have the same problem hopefully someone can check our procedures and see if its us or a program bug.

Tnx es 73
Chuck

User avatar
KA1WPM
Advanced Class
Posts: 31
Joined: 05 May 2015, 14:57
Location: Winsted, CT, USA

Re: USA-CA award Not Found errors

Post by KA1WPM » 08 Aug 2015, 14:27

Hi Chuck,

I don't think this is a bug as much as a corner case for us. The queries that Terry provided to a reasonable job taking the state and county definitions from the QSO records and create the Award Program entries for each QSO. They save a lot of time. However, there is a little disconnect with the counties that have more than one word in the name. Also, there isn't a rule on how names are entered in the county field. Is it Saint, St, or Ste? Who knows? You can put anything in that county field.

Terry's queries work from the text in various fields, but that can't guarantee that the text will match the text in the "official" list seen in the Awards Manager. Once it's in the "Award Program" field on the "Awards" tab for the QSO, it stays there until you take it out. By the way, the awards utility itself is looking at the Awards Program field, not the county and state fields under the "Country IOTA SOTA" tab of the QSO. The good news is that I have been able to resolve every NOT FOUND case that I have worked on. The bad news is that I have done it on a QSO-by-QSO basis, so it takes a bit of time.

This is how it looks to me, but I am just a user like you. Good luck with the hunt, Chuck!

73,
-- Dana, KA1WPM
-- Dana, KA1WPM

Post Reply