Imported log and QSL award flags

Moderator: EI7JZ

Post Reply
w9tvx
Novice Class
Posts: 14
Joined: 08 Nov 2015, 19:36

Imported log and QSL award flags

Post by w9tvx » 11 Jan 2017, 04:15

I've imported my log into Log4OM from HRD, and in the award tracking section (WAS Mixed in this case) I have noticed that none of my LotW granted QSLs are showing up as granted

So I have manually marked QSOs as submitted using the right click submit QSL menu option in the awards window and then picking the QSL that matches the one LotW has credited from the popped up window. I then manually marked each QSL as granted since the award action menu item for moving from submitted to granted doesn't seem to do anything.

I'm hoping that I'm going about this in the wrong way and that there is a better and more automated way of doing this as I really don't want to go through the above steps for every award

Thank you in advance for your help

Ross
w9tvx

K7PT
Moderator
Posts: 642
Joined: 21 Jan 2013, 14:54

Re: Imported log and QSL award flags

Post by K7PT » 11 Jan 2017, 09:17

Try doing a LOTW download using the beginning date as the date of the oldest QSO you have. It should download all your LOTW matches and update each QSO with the award status.
K7PT-Chuck "#1 Top of the Honor Roll"

w9tvx
Novice Class
Posts: 14
Joined: 08 Nov 2015, 19:36

Re: Imported log and QSL award flags

Post by w9tvx » 12 Jan 2017, 18:50

K7PT wrote:Try doing a LOTW download using the beginning date as the date of the oldest QSO you have. It should download all your LOTW matches and update each QSO with the award status.
Thank you for your response. So I cleared the credit submitted and credit granted fields using the QSL Archive feature, then I re-downloaded from LotW from the oldest QSO I have, I noted that the credit submitted/granted fields are being populated appropriately post download. However, I'm still having the same problem for WAS awards.

I did a little more digging and I noticed that LotW is showing 'WAS' in the credit granted fields for QSOs for which a WAS credit has been granted. When I mark a QSO as 'credit submitted' in Log4OM, it seems as if much more detailed flags are added e.g. WAS_MIXED. So perhaps Log4OM is not recognising the 'WAS' value in the credit granted field?

If this is the case, it might explain why the action -> mark sumitted as granted is failing for WAS award i.e. because there is already a value in the credit granted field i.e 'WAS' which is the value that LotW populated.

Or as is much more likely, I might just be doing everything wrong :D

K7PT
Moderator
Posts: 642
Joined: 21 Jan 2013, 14:54

Re: Imported log and QSL award flags

Post by K7PT » 12 Jan 2017, 22:52

I would not worry about the "Submitted" status at all. That is mostly for managing paper cards and snail mail submissions. If LOTW contains the "Granted" status Log4OM should recognize that and set the Granted check box for that QSO.

If this is not happening, there is something wrong.

I've worked all 50 states but have never submitted them for credit in any fashion so can't check it here.
K7PT-Chuck "#1 Top of the Honor Roll"

w9tvx
Novice Class
Posts: 14
Joined: 08 Nov 2015, 19:36

Re: Imported log and QSL award flags

Post by w9tvx » 13 Jan 2017, 04:58

K7PT wrote:I would not worry about the "Submitted" status at all. That is mostly for managing paper cards and snail mail submissions. If LOTW contains the "Granted" status Log4OM should recognize that and set the Granted check box for that QSO.

If this is not happening, there is something wrong.

I've worked all 50 states but have never submitted them for credit in any fashion so can't check it here.
I'm seeing the string 'WAS' in the creditgranted field of QSOs as downloaded from LotW; however, Log4OM is not showing any of them as granted in the WAS award screens. I just don't know enough about the internal workings of Log4OM to know if that is a bug or not. The only hint I have is that Log4OM sets up a different set of strings when I mark a QSO as submitted for a WAS award e.g. WAS_MIXED etc. I can provide screen shots or any other data if this will help.

That said, it's hard to believe that this is a bug in Log4OM since I would have thought others would have run into it, in which case I'd love to know what I am doing incorrectly

K7PT
Moderator
Posts: 642
Joined: 21 Jan 2013, 14:54

Re: Imported log and QSL award flags

Post by K7PT » 13 Jan 2017, 10:30

We are looking at this and it appears that in the current version (V1), WAS/LOTW integration is not available. It will be contained in V2 when available sometime late 2017.

So, the user for the short term must manage WAS in a manual mode (QSO by QSO).
K7PT-Chuck "#1 Top of the Honor Roll"

w9tvx
Novice Class
Posts: 14
Joined: 08 Nov 2015, 19:36

Re: Imported log and QSL award flags

Post by w9tvx » 14 Jan 2017, 05:46

K7PT wrote:We are looking at this and it appears that in the current version (V1), WAS/LOTW integration is not available. It will be contained in V2 when available sometime late 2017.

So, the user for the short term must manage WAS in a manual mode (QSO by QSO).

Sounds good. thank you for looking into this and helping sort it out. Looking forward to v2!

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 3 guests