Playing an alert alarm sound

Post Reply
hfsparks
Advanced Class
Posts: 35
Joined: 24 Oct 2017, 13:56

Playing an alert alarm sound

Post by hfsparks » 22 Feb 2021, 10:24

Hello Terry,
I have a problem with the audio on alerts.

If an alerted station is reported on a cluster the audio won’t sound.
Have set/enabled:
- sound on in the software configuration - cluster/alert settings and have choosen a sound.
when i activate the speaker symbol, no sound.
- In hardware configuration: audio devices and voice keyer:
Selected: To radio /speaker: PHL 243V5 Intel(R) display aud,1]

I use the speaker of my monitor for the alarms.

My config is: wsjtx – jtalert – Log4OM.

Observed:
1. Alarms ar working fine and are displayed in the alarm window.
2. If an alarm is activated during a TX session, the audio is played on the air.
3. The alarm function in JTAlert is functioning okay via the monitor (disabled this funtion but no result for log4om).

Is there any solution to split the audio so that i can do an TX while any alert alarm will be
played via my monitor sound? Or do i need an e.g. external sound (USB) card and speaker for
listening to these alarms?

Best regards,

Gerrit – PA3DJY

User avatar
G4POP
Log4OM Alpha Team
Posts: 8165
Joined: 21 Jan 2013, 14:55
Location: Burnham on Crouch, Essex UK

Re: Playing an alert alarm sound

Post by G4POP » 22 Feb 2021, 11:15

hfsparks wrote:
22 Feb 2021, 10:24

- In hardware configuration: audio devices and voice keyer:
Selected: To radio /speaker: PHL 243V5 Intel(R) display aud,1]
WRONG

If you set that! ALL audio from the PC will be transmitted by your radio, you should select ONLY the audio codecs used for transmission of DAT or Voice keyer sounds.

In the same config window set the recording device as your PC microphone and Listening device as your PC Speaker

CORRECT ALERT SOUND SETTINGS

In Settings/program configuration/CLUSTER select the ALERTS tab

Check ENABLE ALERTS and select the sound required

Click the speaker icon to listen to the sound selected

If you hear the sound when the speaker icon is clicked then you will hear the alert sonds
73 Terry G4POP

hfsparks
Advanced Class
Posts: 35
Joined: 24 Oct 2017, 13:56

Re: Playing an alert alarm sound

Post by hfsparks » 22 Feb 2021, 12:06

Thanks Terry,

Clear explenation.
But i miss something.
I use a Philips monitor with build in sound.
The drivers are installed as PHL 243V5 and i see this option also under "To radio (speaker)".
But i understand i have to select ONLY the standard audio codecs there.
I included 2 screenshots.

I have executed all the instructions you gave me but no sound is coming from my TV monitor (checked sound is on
and it is working in JTAlert).

Could there be another way to achieve this?

Gerrit

hfsparks
Advanced Class
Posts: 35
Joined: 24 Oct 2017, 13:56

Re: Playing an alert alarm sound

Post by hfsparks » 22 Feb 2021, 12:08

Sorry forget the screenshots.
Attachments
Cluster alerts screenshot.JPG
Cluster alerts screenshot.JPG (63.85 KiB) Viewed 151 times
Audio devices and voice keyer screenshot.JPG
Audio devices and voice keyer screenshot.JPG (91.61 KiB) Viewed 151 times

User avatar
G4POP
Log4OM Alpha Team
Posts: 8165
Joined: 21 Jan 2013, 14:55
Location: Burnham on Crouch, Essex UK

Re: Playing an alert alarm sound

Post by G4POP » 22 Feb 2021, 12:35

hfsparks wrote:
22 Feb 2021, 12:06
Thanks Terry,

Clear explenation.
But i miss something.
I use a Philips monitor with build in sound.
The drivers are installed as PHL 243V5 and i see this option also under "To radio (speaker)".
But i understand i have to select ONLY the standard audio codecs there.
I included 2 screenshots.

I have executed all the instructions you gave me but no sound is coming from my TV monitor (checked sound is on
and it is working in JTAlert).

Could there be another way to achieve this?

Gerrit
Have you selected the Phillips sound device as the default sound device in Windows!
73 Terry G4POP

hfsparks
Advanced Class
Posts: 35
Joined: 24 Oct 2017, 13:56

Re: Playing an alert alarm sound

Post by hfsparks » 22 Feb 2021, 13:01

Great, that did the trick!
All working now Terry.

Have a nice day and please stay safe.

Cu and 73's
Gerrit

hfsparks
Advanced Class
Posts: 35
Joined: 24 Oct 2017, 13:56

Re: Playing an alert alarm sound

Post by hfsparks » 23 Feb 2021, 09:15

Hello Terry,

Good morning.

I was to fast with my comment about working ok now.

My remark was correct, when i select the PHL 243V5 as default sound device the alarm sounds via my monitor speaker.
So that is working okay. The only problem then arose that all the sounds, including the signal that used to go to me rig
also goes to my monitor speaker. So my rig does not get keyed but do hear nice FT8 signals on my monitor speaker :?
So it seems that my normal default to key my rig, Realtek high definition audio, is switched off by this selection.

Strange thing, i switched back to the Realtek as default, rig get keyed as normal and the alarm sound set in JTAlert
for receiving a message (set to PHL 243V5) does its work just fine.

Are there any options left?

Regards,
Gerrit
Attachments
Sound config.JPG
Sound config.JPG (37.64 KiB) Viewed 123 times

User avatar
G4POP
Log4OM Alpha Team
Posts: 8165
Joined: 21 Jan 2013, 14:55
Location: Burnham on Crouch, Essex UK

Re: Playing an alert alarm sound

Post by G4POP » 23 Feb 2021, 09:25

It is quiet simple really

The default windows device plays alerts from all programs like Facebook, messenger and log4om, music player, YouTube etc

In wsjt you select the audio device connected to your radio, as you don't state anything about your radio or it's interface to the PC I cannot guess if it would be a sound card or a USB Codec

Triggering PTT is by whatever connection you use, perhaps by CAT or maybe you use a Signaling in which case it uses the radio VOX system

Bottom line is you need to study your set up and make the correct connections depending on rig and interfaces
73 Terry G4POP

hfsparks
Advanced Class
Posts: 35
Joined: 24 Oct 2017, 13:56

Re: Playing an alert alarm sound

Post by hfsparks » 23 Feb 2021, 09:36

Ok Terry, i will do that.
Thanks for your time.

Have a nice day and stay safe.

73's
Gerrit

Post Reply