LoTW upload overriding station location

Post Reply
oh8fks
Novice Class
Posts: 24
Joined: 12 Jan 2018, 17:18

LoTW upload overriding station location

Post by oh8fks » 11 May 2020, 09:12

Since TQSL version 2.5.2 it is possible to choose “Override Station Location with QTH Details from your Log” on the “Log Handling” preference page. This is a (big) improvement for a roving station (this is, working from multiple grid squares) in order to avoid to add a new station location in TQSL each time the own grid changes.

In the latest Log4OM 2 version 2.5.0.0, I tried to upload to LoTW a QSO where MY_GRID differs from the Station ID chosen in User Configuration – External Services – LOTW – Station ID.

Uploading from Log4OM 2 an error window from TQSL pops up warning of the different ”Gridsquare” value as compared. In that window I have the option to choose ”Ignore” to continue signing the log ignoring this ”error”.
Clicking "Ignore" it goes back to the Log4OM 2 upload window which informs me that:

08:27:48: Error: Station Location does not match QSO details
08:27:48: The Station Location 'Gridsquare' has value 'KK00aa' while QSO has 'KK00bb' on line 10
08:27:48: No records to upload
08:27:48: Final Status: Some QSOs suppressed(9)
08:27:48: Some QSOs were duplicate or out of date range (some QSOs written)

And the QSO is not uploaded.

If I export the same entry as ADIF and upload it to LoTW directly through the TQSL interface (using a Station Location that doesn’t match the gridsquare of the the QSO), the log is uploaded with the correct gridsquare, that is the one in the ADIF file instead of the Station Location chosen. And without giving any warning of mismatch.

Is the problem in the Log4OM 2 upload interface?

Post Reply