Saving date range filter not working

V2 error reports
Post Reply
K2GAV
Novice Class
Posts: 18
Joined: 02 Aug 2020, 01:00

Saving date range filter not working

Post by K2GAV » 02 Aug 2020, 08:00

When I create a date range filter such as: log.qsodate >= 1/1/2020 00:00:00 AND log.qsodate <= 12/31/2020 23:59:59, the filter works, but when I save it and then recall it, while it says there are three items selected, the query parameters box is empty and the filter does not work.

I can create and use a date range filter, but I cannot store it and later recall it with it working.

Ted Szypulski
K2GAV
Best wishes,
Ted Szypulski
K2GAV
Kenwood TS-990, Heathkit SB1000

User avatar
G4POP
Log4OM Alpha Team
Posts: 7282
Joined: 21 Jan 2013, 14:55
Location: Burnham on Crouch, Essex UK

Re: Saving date range filter not working

Post by G4POP » 06 Aug 2020, 06:37

I have just been checking this and its working fine for me, I created several different filters including two data range as in you example and they all recall and function on recall perfectly.

BTW you dont need to use AND that is the default
73 Terry G4POP

K2GAV
Novice Class
Posts: 18
Joined: 02 Aug 2020, 01:00

Re: Saving date range filter not working

Post by K2GAV » 06 Aug 2020, 17:20

Thanks Terry. So, here's the bug, if you do use AND, then it doesn't work correctly on recall, but does upon creation. It isn't intuitive to me that you must NOT use AND when logically an AND is required. Even though the button says DEFAULT, it doesn't imply to me, at least, that you must NOT use it.

I'm saving and using it now without the AND.
Best wishes,
Ted Szypulski
K2GAV
Kenwood TS-990, Heathkit SB1000

Post Reply