Mode reported to DX Cluster incorrect

General discussions about Log4OM features
User avatar
W7DRM
Log4OM Alpha Team
Posts: 533
Joined: 19 Feb 2014, 19:44

Re: Mode reported to DX Cluster incorrect

Post by W7DRM » 05 Mar 2017, 21:52

Robert,

Keep in mind, the bandplan has no bearing on how the spot is sent. Your spot was sent as SSB, no worries there. The bandplan comes into play in how the Cluster display sets the Mode field for a particular spot.

Doug - W7DRM

WA2SQQ
Old Man
Posts: 104
Joined: 16 Feb 2015, 20:13
Location: New Jersey US

Re: Mode reported to DX Cluster incorrect

Post by WA2SQQ » 07 Mar 2017, 19:28

I appreciate your explanation, but I'm still no closer to solving this. If I send a "spot" on or near that frequency, while operating SSB, it shows up on the cluster as DIGITAL. LOG4OM's log file shows it correctly as a phone contact using SSB. Just trying to figure out what needs to be changed so that the spots get sent correctly. I've also tried another cluster with the same results.

Hopefully this will get fixed in V2.0

User avatar
W7DRM
Log4OM Alpha Team
Posts: 533
Joined: 19 Feb 2014, 19:44

Re: Mode reported to DX Cluster incorrect

Post by W7DRM » 10 Mar 2017, 09:18

Robert,

In your example, the spot is NOT being sent as DIGITAL. Your spot is being sent by frequency only. What you are seeing in the Cluster display MODE field is Log4OM's interpretation of the MODE, based on the bandplan files. Its only an interpretation, not what you sent.

Doug - W7DRM

User avatar
IW3HMH
Site Admin
Posts: 2277
Joined: 21 Jan 2013, 14:20
Location: Quarto d'Altino - Venezia (ITA)
Contact:

Re: Mode reported to DX Cluster incorrect

Post by IW3HMH » 14 Mar 2017, 13:16

Right.
Band plan is applied on received spot (that doesn't contain mode informations). Log4OM uses the USER bandplan to identify the region.

Sometime can happens that a spot that appears as DIGITAL is in the PHONE bandplan area in another IARU region (the spotted callsign region).
In that case the spot is reported according to YOUR bandplan. That means if you answer to this call (that is actually an SSB call), you are using voice in a DIGITAL bandplan region for your location.
Daniele Pistollato - IW3HMH

WA2SQQ
Old Man
Posts: 104
Joined: 16 Feb 2015, 20:13
Location: New Jersey US

Re: Mode reported to DX Cluster incorrect

Post by WA2SQQ » 30 Jul 2017, 01:57

W7DRM wrote:
05 Mar 2017, 00:19
Hi Robert,

Your bandplan file determines which mode is displayed in the Mode field of your Cluster display.

To solve this, go to your configuration folder (Help/Open Configuration Folder), and find the bandplan291.xml file. (see last paragraph, below, if you do not have this file). Open that file with Notepad. Scroll down to the section on 40m. If yours is like mine, the BandPlanRange for 7035 to 7150 is designated as "Digital". Your spot of 7,137 is in this range. Basically the Mode field in the Cluster display uses this plan to determine mode, not the mode sent in the spot report. So your spot was correct, just the interruption of the spot in your Log4OM cluster was off, due to the band plan.

If you want to alter this band plan, you can copy this file to a file called bandplan291_user.xml, then modify the plan to make the Digital section smaller or as you wish. That way, your bandplan291_user.xml file will be preserved after a program update where there may be a new bandplan291.xml file furnished.

I should also mention that there is a hierarchy of bandplan files. If you do not have a bandplan291.xml file (291 DXCC entity), then the bandplan_r2.xml file is used. (Region 2). So you can create a bandplan_r2_user.xml file if you do not have a bandplan291.xml file.

Doug - W7DRM
Doug,
Finally decided to try and fix this.
1. The file you mentioned, bandplan_291.xml di not exist. I do have bandplan_dxcc291.xml.
2. Perhaps I made a bad decision, but I edited the digital portion of that file, to change 7150 down to 7125.
3. Now, as soon as I go below 7150, LOG4OM shows OUT OF BAND, regardless of what mode I'm in.
4. I suppose I can just install LOG4OM on another PC and copy that XML file over the one I modified.
5 I also have the bandplan_r1 (through) _r3. Not sure about hos these are used, and why _r2 would be used before _R1.
I've included the 40m portion of bandplan_dxcc291 below. I'm really sorry to reintroduce this issue ... I guess this is one of the artifacts of getting old!

<BandPlanRange>
<Band>40m</Band>
<Start>7000</Start>
<End>7035</End>
<BandUpperLimit>false</BandUpperLimit>
<EmissionType>CW</EmissionType>
<ModulationType>USB</ModulationType>
</BandPlanRange>
<BandPlanRange>
<Band>40m</Band>
<Start>7035</Start>
<End>7125</End>
<BandUpperLimit>false</BandUpperLimit>
<EmissionType>DIGITAL</EmissionType>
<ModulationType>USB</ModulationType>
</BandPlanRange>
<BandPlanRange>
<Band>40m</Band>
<Start>7150</Start>
<End>7300</End>
<BandUpperLimit>true</BandUpperLimit>
<EmissionType>PHONE</EmissionType>
<ModulationType>LSB</ModulationType>
</BandPlanRange>
<BandPlanRange>

WA2SQQ
Old Man
Posts: 104
Joined: 16 Feb 2015, 20:13
Location: New Jersey US

Re: Mode reported to DX Cluster incorrect

Post by WA2SQQ » 30 Jul 2017, 02:44

I got the out of band issue corrected.
So here is the 40m portion of Bandplan_r2.xml
7035-to 7125 is already designated for "digital" if I am understanding this correctly. Yet, any spot on the cluster (SSB) only shows up as "digital" in LOG4OM.
I apologize for not understanding this - hopefully someone can set me straight.

<BandPlanRange>
<Band>40m</Band>
<Start>7000</Start>
<End>7035</End>
<BandUpperLimit>false</BandUpperLimit>
<EmissionType>CW</EmissionType>
<ModulationType>USB</ModulationType>
</BandPlanRange>
<BandPlanRange>
<Band>40m</Band>
<Start>7035</Start>
<End>7125</End>
<BandUpperLimit>false</BandUpperLimit>
<EmissionType>DIGITAL</EmissionType>
<ModulationType>USB</ModulationType>
</BandPlanRange>
<BandPlanRange>
<Band>40m</Band>
<Start>7125</Start>
<End>7300</End>
<BandUpperLimit>true</BandUpperLimit>
<EmissionType>PHONE</EmissionType>
<ModulationType>LSB</ModulationType>
</BandPlanRange>

User avatar
W7DRM
Log4OM Alpha Team
Posts: 533
Joined: 19 Feb 2014, 19:44

Re: Mode reported to DX Cluster incorrect

Post by W7DRM » 30 Jul 2017, 20:00

WA2SQQ wrote:
30 Jul 2017, 02:44
I got the out of band issue corrected.
So here is the 40m portion of Bandplan_r2.xml
7035-to 7125 is already designated for "digital" if I am understanding this correctly. Yet, any spot on the cluster (SSB) only shows up as "digital" in LOG4OM.
I apologize for not understanding this - hopefully someone can set me straight.
Hi Robert,

Correct. These bandplan files only effect what mode the spot is believed to be, according to the band plan - only affecting the Mode column in the Log4OM cluster display.

One other point. Log4OM uses the bandplan-r2.xml file if it does not find a bandplan_dxccXXX.xml file - (XXX) being the DXCC number of your QTH, in our case - 291. Plus, if Log4OM finds a bandplan_dxccXXX_user.xml file, it will use that over the generic bandplan_dxccXXX.xml file.

So the hierarchy of bandplan files are from lowest priority to highest:
bandplan_rX.xml - your region - in our case, IARU region 2
bandplan_rX_user.xml - your region file customized
bandplan_dxccXXX.xml - your dxcc country - in our case - 291
bandplan_dxccXXX_user.xml - your dxcc country customized for you.

The ...._user.xml file are used so that your changes are not overriden by a Log4OM program update which might include a newer version of the region or dxcc bandplan files.

So, in order to preserve the changes which you have made, and make them effective, you need to modify a copy of the Bandplan_dxcc291.xml file - which is for the U.S. specifically. So make a copy of the bandplan_dxcc291.xml file, then rename that copied file to bandplan_dxcc291_user.xml. Then in that new file, make the same changes to the 40 meter segment which you have outlined above. Then you should be set, and won't lose those changes the next time you upgrade Log4OM.

Doug - W7DRM

User avatar
W2MJP
Advanced Class
Posts: 49
Joined: 22 Dec 2016, 00:40

Re: Mode reported to DX Cluster incorrect

Post by W2MJP » 22 Jan 2019, 00:37

WA2SQQ wrote:
04 Mar 2017, 14:01
Worked a station on 40M SSB, on 7.137
The contact was logged as SSB, but the spot to the DX cluster was designated as DIGITAL.
I see this is a old thread but I to am having the same problem. I asked this question in a recent forum but stumbled upon this trying to fix the problem. I believe my settings are correct as I am in region 1 I think. Anything below 7.150 shows as digital and when I use my CAT control to click and go to that freq the radio goes into USB. I guess all of this time I have been saving theses qso as digital? How can this be corrected? Thanks.
Mike-W2MJP

User avatar
G4POP
Moderator
Posts: 5523
Joined: 21 Jan 2013, 14:55
Location: Burnham on Crouch, Essex UK

Re: Mode reported to DX Cluster incorrect

Post by G4POP » 22 Jan 2019, 08:19

Well according to your call sign your in region 2?
73 Terry G4POP

User avatar
DF5WW
Log4OM Alpha Team
Posts: 999
Joined: 02 May 2013, 09:49
Location: Höhr-Grenzhausen, Rhineland Palatinate, Germany
Contact:

Re: Mode reported to DX Cluster incorrect

Post by DF5WW » 22 Jan 2019, 09:27

Think so too. IARU R1 is Europe and parts of Africa. There´s a nice WIKI to find
out what is in which region:

https://en.wikipedia.org/wiki/Internati ... adio_Union

:) :)
73´s .. Juergen ... RedPitaya SDR 5 W, 20 mtr. indoor wireloop feeded with homemade ladderline (600 Ohms) ...

Post Reply