hamlib questions

General discussions about Log4OM features
Post Reply
w9mdb
Advanced Class
Posts: 78
Joined: 13 Jul 2014, 13:05

hamlib questions

Post by w9mdb » 19 Mar 2018, 18:56

#1 Is it possible for Log4OM to remember to start up hamlib -- preferably both standalone or already running?

#2 I'd recommend hamlib be upgraded since what's in Log4OM is 3 years old and missing a lot of newer rigs and other capabilities. I'm planning on adding OmniRig as one of the rigs in hamlib so hamlib would a 1-stop shop for OmniRIg, FLRig, or local controls.

de Mike W9MDB

User avatar
KI5IO
Old Man
Posts: 106
Joined: 16 Aug 2015, 17:30

Re: hamlib questions

Post by KI5IO » 21 Mar 2018, 01:23

You can select Hamlib or OmniRig as the default CAT in the setup for cat/cluster in Log4OM.

I believe, if you search the forum, you will find where Terry and Lele have noted that updating to the more current version of Hamlib would take extensive programming changes and is not on the list for this version of Log4OM. It is planned for the new version as I recall.
73 - Nolan Kienitz - KI5IO
Plano, TX

w9mdb
Advanced Class
Posts: 78
Joined: 13 Jul 2014, 13:05

Re: hamlib questions

Post by w9mdb » 03 Apr 2018, 00:02

Turns our the Hamlib Net rigctl entry does work with the current version of hamlib's rigctld so that solves my problem and would also be a solution for anybody else that wants CAT control on a rig not supported in the old version.
I now have Log4OM, WSJT-X, and FLdigi all talking to FLRig successfully with the changes I've made to hamlib's flrig backend.

So I'll be submitting this patch soon.

Meanwhile...is there a way to control the polling rate that Log4OM is doing? It's going 2 times per second right now which seems a bit excessive.

de Mike W9MDB

w9mdb
Advanced Class
Posts: 78
Joined: 13 Jul 2014, 13:05

Re: hamlib questions

Post by w9mdb » 11 Apr 2018, 19:53

I've found I can copy rigctld and these files

12/19/2014 09:54 PM 507,989 libgcc_s_sjlj-1.dll
03/31/2018 08:13 AM 2,613,248 libhamlib-2.dll
09/13/2015 08:00 PM 252,580 libusb-1.0.dll
01/21/2015 05:40 PM 67,008 libusb0.dll
09/11/2014 04:34 PM 251,903 libwinpthread-1.dll

And Log4OM can connect to everything in the new version. I updated riglist.txt to show the new rigs.

I am now trying to run either hamlib NET rigctl or the FLRig entry. I can get both to run just by using the parameter "--model=2" or "--model=4". But every time I start Log4OM the parameter string gets replaced by the full string which is incorrect. I then have to go in, erase all the extra params, and Open it again.
The "Save Parameter" button doesn't seem to really save anything.
So how can I get the Parameters to stay constant?
de Mike W9MDB

w9mdb
Advanced Class
Posts: 78
Joined: 13 Jul 2014, 13:05

Re: hamlib questions

Post by w9mdb » 12 Apr 2018, 13:28

I'll add that I can click "Load Parameter" and it will bring in the remembered settings.
But that isn't done during startup?

Mike

Post Reply