Log4OM - JTAlertX - WSJT-X intercommunication signal strength logging

General discussions about Log4OM features
Post Reply
N0DL
New user
Posts: 1
Joined: 14 Oct 2018, 13:55

Log4OM - JTAlertX - WSJT-X intercommunication signal strength logging

Post by N0DL » 14 Oct 2018, 15:26

I am using WSJT-X with JTAlertX to automatically log my QSOs. I have noticed any FT8 signal report of 00dB, sent or received ends up as +30dB in the Log4OM data. I have been watching for that 00dB reports and manually editing them to change the +30dB to 00dB but I thought I would point this out in case there's a bug that is translating just that one signal strength report incorrectly. This is such a minor problem that I hate to even bring it up but it has been happening to me since I started using Log4OM so it might be affecting others. I don't know if the error is the handoff between WSJT-X or if JTAlertX might be doing this. Sorry if this was asked and answered elsewhere. I tried finding it in the forum but searches for 30dB and 00dB yielded no results.

User avatar
G4POP
Moderator
Posts: 5068
Joined: 21 Jan 2013, 15:55
Location: Burnham on Crouch, Essex UK

Re: Log4OM - JTAlertX - WSJT-X intercommunication signal strength logging

Post by G4POP » 14 Oct 2018, 22:40

What Log4OM version are you using - Version number please
73 Terry G4POP

User avatar
IW3HMH
Site Admin
Posts: 2208
Joined: 21 Jan 2013, 15:20
Location: Quarto d'Altino - Venezia (ITA)
Contact:

Re: Log4OM - JTAlertX - WSJT-X intercommunication signal strength logging

Post by IW3HMH » 25 Oct 2018, 10:01

This happens because Log4OM has a predefined list of signals, saved in "reportlistJT.txt" file

If signal value received is not in that list, it will be defaulted to the * marked value in the list.

Current file has "00" for 0db
If JTAlert is reporting +00 it will not match, and the default value is the +30

To fix that:

open settings folder (available also from HELP menu)
COPY file reportlistJT.txt to reportlistJT_user.txt (COPY DO NOT REMOVE ORIGINAL FILE)
EDIT reportlistJT_user.txt changing 00 to +00 (or the value coming from JTAlert)
Save and restart Log4OM

Note: check for your previous QSO logged, as they may not find their 00 in the new list and go back defaulting to 30db

Another possibility (less clean imho) is to add +00 near the 00 value so old QSO will show 00 and new ones the +00 value
Daniele Pistollato - IW3HMH

Post Reply