ic-7300 CAT problem- delay

Need help? - Post here and we will find a solution for you.
User avatar
G4DWV - Guy
Old Man
Posts: 280
Joined: 11 Sep 2014, 17:02

Re: ic-7300 CAT problem- delay

Post by G4DWV - Guy » 06 Oct 2017, 15:32

The driver that Icom uses is a very old generic driver. I have upgraded the driver to the latest one available.

Icom uses a Silicon Labs chipset and the latest drivers are here https://www.silabs.com/products/develop ... cp-drivers. I have been using them for ages without any issue.

Backup or make a system restore point before messing about in case you get yourself into a situation where you wish you had done that in the first place. A system restore point is much quicker to do and even though I make a full backup daily, I would use that.

73 de Guy G4DWV 4X1LT
You've never known happiness until you're married; but by then it is too late.

sq7bcn
Novice Class
Posts: 21
Joined: 24 Sep 2017, 16:04

Re: ic-7300 CAT problem- delay

Post by sq7bcn » 11 Oct 2017, 10:41

So you're sirting to change the Icom driver to the one you're linking to?

User avatar
G4POP
Moderator
Posts: 4295
Joined: 21 Jan 2013, 15:55
Location: Burnham on Crouch, Essex UK

Re: ic-7300 CAT problem- delay

Post by G4POP » 11 Oct 2017, 13:20

I would suggest that you do nothing if it's all working ok?

If it ain't broke don't fix it!
73 Terry G4POP

DF5WW
Old Man
Posts: 720
Joined: 02 May 2013, 10:49
Location: Höhr-Grenzhausen, Rhineland Palatinate, Germany
Contact:

Re: ic-7300 CAT problem- delay

Post by DF5WW » 11 Oct 2017, 13:35

G4POP wrote:
11 Oct 2017, 13:20
If it ain't broke don't fix it!
Or: Never change a running system, HI ;) ;)
73´s .. Juergen ... RedPitaya SDR 5 W, 20 mtr. indoor wireloop feeded with homemade ladderline (600 Ohms) ...

sq7bcn
Novice Class
Posts: 21
Joined: 24 Sep 2017, 16:04

Re: ic-7300 CAT problem- delay

Post by sq7bcn » 12 Oct 2017, 10:06

But I checked but unfortunately I had to go back to the old driver because Omnirig was not working, other programs worked fine.

User avatar
G4DWV - Guy
Old Man
Posts: 280
Joined: 11 Sep 2014, 17:02

Re: ic-7300 CAT problem- delay

Post by G4DWV - Guy » 16 Oct 2017, 14:07

sq7bcn wrote:
12 Oct 2017, 10:06
But I checked but unfortunately I had to go back to the old driver because Omnirig was not working, other programs worked fine.
What do you mean by "not working" when you talk about Omnirig? I changed my drivers back to the old ones and my issues with Omnirig have not been solved. I just cannot use Omnirig at all. Luckily, for my activities, I use WSJT-X and Fldigi, I do not need Omnirig at all. The frequency gets logged correctly and I do not use clusters. Also, I have no desire to post an "on air" indication to HRDlog. I use an external interface for Digimodes and Omnirig should work with that too. Omnirig just seems to be unable to share com ports, which it is supposed to do out of the box. That is just how my problems appear.

When I work phone and CW, I load Omnirig manually so that my frequency is logged.

It is a shame that Log4OM does not use hamlib3 as that is installed with JTDX and WSJT-X and works perfectly. Hamlib 2 and hamlib 3 are so different, I will have to wait until Log4OM 2 in order to be able to use hamlib 3. My rig is not supported in hamlib 2.

73 de Guy G4DWV 4X1LT
You've never known happiness until you're married; but by then it is too late.

User avatar
G4POP
Moderator
Posts: 4295
Joined: 21 Jan 2013, 15:55
Location: Burnham on Crouch, Essex UK

Re: ic-7300 CAT problem- delay

Post by G4POP » 16 Oct 2017, 15:28

Omnirig just seems to be unable to share com ports, which it is supposed to do out of the box.
Omnirig does the effect of port sharing by multi threading but only with software that is designed to do multi threading e.g. the rest of Alex's programs like Bandmaster CW-Skimmer etc. and external software like Log4OM and SDR-Radio Consul etc..

However all of those programs including Omnirig must be 'Run as an administrator' the user being the administrator is not the same thing! and it is also essential to use the latest version of Omnirig.

The most frequent issue with the IC7100, 7300 >> is the user not installing the USB drivers before connecting the radio! If a user connects the radio and then installs the drivers then the drivers must be uninstalled and the installation process started again from square one.
73 Terry G4POP

User avatar
G4DWV - Guy
Old Man
Posts: 280
Joined: 11 Sep 2014, 17:02

Re: ic-7300 CAT problem- delay

Post by G4DWV - Guy » 16 Oct 2017, 18:51

Hi Terry,

Thanks for your post.

Everything is present and correct driver-wise. I downgraded my drivers to the original Icom drivers, which are just unmodified and old Silicon Labs drivers. That did not help.

I have just set my digital interface software to run as admin, not my changing the shortcut, but by modifying the executable itself. I

I have been told that there is or should be no problem with Omnirig playing nice with my digi interface program, but it does not here.

I keep on trying to get to the bottom of this, but without success. I do not really need what Omnirig gives as I said above. It is just damn annoying that as it should work, I want it to :D .

73 de Guy G4DWV 4X1LT
You've never known happiness until you're married; but by then it is too late.

sq7bcn
Novice Class
Posts: 21
Joined: 24 Sep 2017, 16:04

Re: ic-7300 CAT problem- delay

Post by sq7bcn » 17 Oct 2017, 08:06

Do it is way:
Remove drivers ICOM (Silicone labs)
Restart PC
Instal Driver ICOM ...
Check parametr in TRX baud rate 115 200 , echo ON, etc..
Conect TRX via USB and set parametrs in Log4ON- OmniRig ,com, baud rate ...

User avatar
G4DWV - Guy
Old Man
Posts: 280
Joined: 11 Sep 2014, 17:02

Re: ic-7300 CAT problem- delay

Post by G4DWV - Guy » 18 Oct 2017, 16:40

Hi SQ7BCN,

I did all of that and uninstalled all the drivers that I had installed. I then got the latest drivers* from the Icom site and installed those exactly as per the instructions. It will be a while before I will be able to tell all is well.

*The Icom drivers are based on quite old Silicon Labs drivers. They are v6.6.1.0 from December 2012. The latest drivers are v6.7.4. All Icom does to "update" the drivers is to modify them for new rigs.

Cheers

Guy
You've never known happiness until you're married; but by then it is too late.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests