Icom 7300 and cat control

Need help? - Post here and we will find a solution for you.
Post Reply
User avatar
G4DWV - Guy
Old Man
Posts: 291
Joined: 11 Sep 2014, 17:02

Icom 7300 and cat control

Post by G4DWV - Guy » 08 Oct 2017, 08:36

Hi,

No matter what I do, I cannot get the CAT status light to get to green.

I do not use omnirig when using FLDigi as I do not use clusters so have not loaded omnirig in a while. I use an external interface (microHAM Digiikeyer II) and if omnirig and that hardware's program are loaded at the same time, my rig would key.

Now when I do want Omnirig to work, it won't.

The forum will not allow most of my searches, saying that the words I am using are too common. My rig is on com 4. Attached are screen shots of Log4OM settings, communicator setting and Omnirig.

I have been going around in circles for ages, for 3 hours (seriously!), to try to figure where I am going wrong.

Can anybody help?

73 de Guy G4DWV 4X1LT
Attachments
2017-10-08_08h33_16.png
2017-10-08_08h33_16.png (62.9 KiB) Viewed 147 times
2017-10-08_08h32_39.png
2017-10-08_08h32_39.png (17.53 KiB) Viewed 147 times
2017-10-08_08h32_22.png
2017-10-08_08h32_22.png (87.96 KiB) Viewed 147 times
You've never known happiness until you're married; but by then it is too late.

User avatar
G4POP
Moderator
Posts: 4393
Joined: 21 Jan 2013, 15:55
Location: Burnham on Crouch, Essex UK

Re: Icom 7300 and cat control

Post by G4POP » 08 Oct 2017, 09:08

I think your issue is more to do with the Virtual Ports that the Digikeyer installs check the Microham user guide
73 Terry G4POP

User avatar
G4DWV - Guy
Old Man
Posts: 291
Joined: 11 Sep 2014, 17:02

Re: Icom 7300 and cat control

Post by G4DWV - Guy » 08 Oct 2017, 09:16

Hi Terry,

I have confirmed that Onirig is not working by running the Omnirig test client.

Cheers

Guy
Last edited by G4DWV - Guy on 08 Oct 2017, 09:28, edited 1 time in total.
You've never known happiness until you're married; but by then it is too late.

User avatar
G4POP
Moderator
Posts: 4393
Joined: 21 Jan 2013, 15:55
Location: Burnham on Crouch, Essex UK

Re: Icom 7300 and cat control

Post by G4POP » 08 Oct 2017, 09:25

If which software is not running?

Is any other software using the com port?
73 Terry G4POP

User avatar
G4DWV - Guy
Old Man
Posts: 291
Joined: 11 Sep 2014, 17:02

Re: Icom 7300 and cat control

Post by G4DWV - Guy » 08 Oct 2017, 11:34

Hi Terry,

I have found out what the issue is, and I am reporting back in case it helps anybody else. It was not due to any other software using the COM port. I used the OmniRig client test software to home in on this. The test program is very useful when checking on OmniRig issue and I would not have discovered the problem as quickly without it.

I had changed the "CI-V Transceive" setting to "on". All is well when the setting is changed back to "off".

Cheers

Guy
You've never known happiness until you're married; but by then it is too late.

sq7bcn
Novice Class
Posts: 23
Joined: 24 Sep 2017, 16:04

Re: Icom 7300 and cat control

Post by sq7bcn » 10 Oct 2017, 09:55

So you had control over CAT off the radio, how was it supposed to work?
"CI-V Transceive" must be ON.
You have RTS and DTR High one should be low ...

User avatar
G4DWV - Guy
Old Man
Posts: 291
Joined: 11 Sep 2014, 17:02

Re: Icom 7300 and cat control

Post by G4DWV - Guy » 10 Oct 2017, 15:40

Hi,

I still have problems with Omnirig. Luckily, I do not need it for any digi modes at all. With JTDX, the rig control is by the latest hamlib that is included with it. I also use JTAlert.

For my other digimodes, I use Fldigi and that setup passes the frequency to the log. In reality, I only need Omnirig when using phone and CW.

It would be nice to get it to work as I do not like to let computers win.

I will carry on trying to get it to work, if only because it *should* work.

73 de Guy
You've never known happiness until you're married; but by then it is too late.

User avatar
G4POP
Moderator
Posts: 4393
Joined: 21 Jan 2013, 15:55
Location: Burnham on Crouch, Essex UK

Re: Icom 7300 and cat control

Post by G4POP » 10 Oct 2017, 16:45

Well I use FLDigi, WSKT-X and JTAlert and none of those program's connect directly to the radio and they are not using Hamlib

WSJT-X shares the Omnirig connection with Log4OM

JTAlert communicates with WSJT-X and logs directly to the Log4OM database

FLDigi communicates with Log4OM using the XML/RPC system and logs direct to the Log4OM database as described in the Log4OM user guide and our YouTube tutorials.

All four programs can run simultaneously if I wanted to
73 Terry G4POP

User avatar
G4DWV - Guy
Old Man
Posts: 291
Joined: 11 Sep 2014, 17:02

Re: Icom 7300 and cat control

Post by G4DWV - Guy » 10 Oct 2017, 17:41

WSJT-X uses hamlib 3 and so does JTDX. When compiling from source, one has to build hamlib 3 first and then WSJT-X. IIRC, WSJT-X will not even compile without hamlib 3

Without Omnirig running, anything I put into the fldigi log field gets sent to Log4OM. I use flrig for rig control. Rigcat and xml-rpc are not used. Both their respective "use" boxes are not ticked. I have just double checked this before sending this post just to be sure. All the connection lights in Communicator are green.

If a video of the proof is needed, I will be happy to supply it.

Cheers

Guy
You've never known happiness until you're married; but by then it is too late.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest