Transmit always on IC-7300

Need help? - Post here and we will find a solution for you.
KJ4JDK
Novice Class
Posts: 4
Joined: 18 Oct 2017, 16:41

Transmit always on IC-7300

Post by KJ4JDK » 18 Oct 2017, 16:44

Hello,

I have a brand new IC-7300 and I have it connected to Log4OM. When I start the program there is a little delay and then the radio goes into transmit mode and stays on until I close the program. Can anyone provide guidance as to why this is occurring?

Thanks,

Jeff
KJ4JDK

User avatar
DF5WW
Moderator
Posts: 754
Joined: 02 May 2013, 10:49
Location: Höhr-Grenzhausen, Rhineland Palatinate, Germany
Contact:

Re: Transmit always on IC-7300

Post by DF5WW » 18 Oct 2017, 17:12

How do you have connected to the Radio ... Hamlib or Omnirig.

If you are using Omnirig have you installed the latest version with the lates.ini files.
Do you run Omnirig with adminitrator privileges (that is a must be).

Installed the ICOM drivers correctly (first install drivers before you connect the radio
to the PC).

;) ;)
73´s .. Juergen ... RedPitaya SDR 5 W, 20 mtr. indoor wireloop feeded with homemade ladderline (600 Ohms) ...

KJ4JDK
Novice Class
Posts: 4
Joined: 18 Oct 2017, 16:41

Re: Transmit always on IC-7300

Post by KJ4JDK » 18 Oct 2017, 17:48

DF5WW wrote:
18 Oct 2017, 17:12
How do you have connected to the Radio ... Hamlib or Omnirig.

If you are using Omnirig have you installed the latest version with the lates.ini files.
Do you run Omnirig with adminitrator privileges (that is a must be).

Installed the ICOM drivers correctly (first install drivers before you connect the radio
to the PC).

;) ;)
1) Omnirig
2) Latest of both. Running in Administrator mode
3) Icom drivers installed without radio attached. Installed before Omnirig.

sq7bcn
Novice Class
Posts: 23
Joined: 24 Sep 2017, 16:04

Re: Transmit always on IC-7300

Post by sq7bcn » 19 Oct 2017, 06:47

The problem is the wrong setting of DTR and RTS signals.
The Icom and OmniRig must be the same.
Set Omnirig RTS High, DTR low- will be fine.
Set Icom RTS ....according to the following:

USB SEND (Default: OFF)
You can control transmit and receive from the PC
through the USB port.
Selects the control port to be used for communication
between the IC-7300 and PC, according to the
operating condition.
••OFF: Turns OFF the function.
••DTR: Uses the DTR terminal on the CI-V (PC) side.
••RTS: Uses the RTS terminal on the CI-V (PC) side.

KJ4JDK
Novice Class
Posts: 4
Joined: 18 Oct 2017, 16:41

Re: Transmit always on IC-7300

Post by KJ4JDK » 19 Oct 2017, 13:22

That was the issue! Thanks for the help!

User avatar
G4DWV - Guy
Old Man
Posts: 291
Joined: 11 Sep 2014, 17:02

Re: Transmit always on IC-7300

Post by G4DWV - Guy » 19 Oct 2017, 16:33

sq7bcn wrote:
19 Oct 2017, 06:47
The problem is the wrong setting of DTR and RTS signals.
The Icom and OmniRig must be the same.
Set Omnirig RTS High, DTR low- will be fine.
Set Icom RTS ....according to the following:

USB SEND (Default: OFF)
You can control transmit and receive from the PC
through the USB port.
Selects the control port to be used for communication
between the IC-7300 and PC, according to the
operating condition.
••OFF: Turns OFF the function.
••DTR: Uses the DTR terminal on the CI-V (PC) side.
••RTS: Uses the RTS terminal on the CI-V (PC) side.
Could you please clarify what the USB SEND setting should be? I still have the CAT and HRDLog ON AIR lights on RED. I have set the RTS and DTR as you have said above.

73 de Guy G4DWV 4X1LT
You've never known happiness until you're married; but by then it is too late.

KJ4JDK
Novice Class
Posts: 4
Joined: 18 Oct 2017, 16:41

Re: Transmit always on IC-7300

Post by KJ4JDK » 19 Oct 2017, 16:36

G4DWV - Guy wrote:
19 Oct 2017, 16:33
sq7bcn wrote:
19 Oct 2017, 06:47
The problem is the wrong setting of DTR and RTS signals.
The Icom and OmniRig must be the same.
Set Omnirig RTS High, DTR low- will be fine.
Set Icom RTS ....according to the following:

USB SEND (Default: OFF)
You can control transmit and receive from the PC
through the USB port.
Selects the control port to be used for communication
between the IC-7300 and PC, according to the
operating condition.
••OFF: Turns OFF the function.
••DTR: Uses the DTR terminal on the CI-V (PC) side.
••RTS: Uses the RTS terminal on the CI-V (PC) side.
Could you please clarify what the USB SEND setting should be? I still have the CAT and HRDLog ON AIR lights on RED. I have set the RTS and DTR as you have said above.

73 de Guy G4DWV 4X1LT
USB Send is set to RTS.

sq7bcn
Novice Class
Posts: 23
Joined: 24 Sep 2017, 16:04

Re: Transmit always on IC-7300

Post by sq7bcn » 20 Oct 2017, 08:59

It is important that it is the same in Icom and Omnirig:
RTS- High
DTR-Low

User avatar
G4DWV - Guy
Old Man
Posts: 291
Joined: 11 Sep 2014, 17:02

Re: Transmit always on IC-7300

Post by G4DWV - Guy » 20 Oct 2017, 13:31

sq7bcn wrote:
20 Oct 2017, 08:59
It is important that it is the same in Icom and Omnirig:
RTS- High
DTR-Low
Hi,

Where do I set RTS and DTR values in the 7300? I have checked the manual and I can only set one or the other in USB send, let alone high or low. I have set these values in omnirig.

My com port is set to that for cat control in my Digikeyer II - that is the correct port to use. If I change the port to that of the rig itself (4), I do get the green lights in Log4OM, but the rig keys.

Thanks

73 de Guy G4DWV 4X1LT
You've never known happiness until you're married; but by then it is too late.

User avatar
G4POP
Moderator
Posts: 4393
Joined: 21 Jan 2013, 15:55
Location: Burnham on Crouch, Essex UK

Re: Transmit always on IC-7300

Post by G4POP » 20 Oct 2017, 14:32

G4DWV - Guy wrote:
20 Oct 2017, 13:31
sq7bcn wrote:
20 Oct 2017, 08:59
It is important that it is the same in Icom and Omnirig:
RTS- High
DTR-Low
Hi,

Where do I set RTS and DTR values in the 7300? I have checked the manual and I can only set one or the other in USB send, let alone high or low. I have set these values in omnirig.

My com port is set to that for cat control in my Digikeyer II - that is the correct port to use. If I change the port to that of the rig itself (4), I do get the green lights in Log4OM, but the rig keys.

Thanks

73 de Guy G4DWV 4X1LT
My guess is that the issue is in your Digikeyer which I believe connects to the ACC socket on your radio - Not to the USB connection on your radio.

I know SFA about Digikeyers but from what I read they create virtual com ports and I think that is what is confusing you!

Did you ever try disconnecting the Digikeyer and use instead the USB printer cable between the radio and computer (Note this is the small square socket on the back of the radio)?
73 Terry G4POP

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest