CONNECT TCP Failing to connect

Need help? - Post here and we will find a solution for you.
Post Reply
BobN
Novice Class
Posts: 3
Joined: 19 Oct 2017, 19:25

CONNECT TCP Failing to connect

Post by BobN » 19 Oct 2017, 19:48

I will be as brief as possible. I would like to use Log4OM as my logging program but for some reason, simple I'm sure, I have not been able to get a green light for CONNECT TCP. On settings screen, I see Internet connection Auto Detect and a green CONNECTED.

Services tab in Settings shows WCF running.

The environment is:
Win 7 Home
AMD quad core 8GB
Omni VII
N4PY for CAT
WSJT-X 1.8.0.rc3
JTAlert 2.10.3
vspMgr
fldigi
DXLab

I loaded Log4M on my laptop just to see if I would get a different result. But I didn't. Same issue.

Thank you for any assistance.
Bob AK5U

User avatar
W7DRM
Moderator
Posts: 480
Joined: 19 Feb 2014, 20:44

Re: CONNECT TCP Failing to connect

Post by W7DRM » 20 Oct 2017, 02:04

Hi Bob,

First off, are you trying to have JTAlert auto log qso's into Log4OM? If so, then you are on the right track. Have you set the Communicator, Settings, Inbound Settings dialog, UDP Connection checked and Port set to 2236? You have to stop Communicator to change those settings. See page 182 of the current User's Manual for the settings. Once set, restart Communicator, but don't close it.

You should then see on the Communicator window a green LED for TCP Connection to Log4OM. If not, then click on the start button next to the line.

Now go back to the Log4OM window. If the two middle LED's at the bottom are not both green, click on the red one and then select Start Connection.

Then make sure JTAlert is set up for Log4OM as also described on page 182 of the Log4OM User's Manual.

If this doesn't help, let us know and we will dig deeper.

BTW, it is customary to use your call as your login name, so that we can see where you are from which helps diagnose issues.. I will go ahead and change your user name to your call.

73,
Doug - W7DRM

BobN
Novice Class
Posts: 3
Joined: 19 Oct 2017, 19:25

Re: CONNECT TCP Failing to connect

Post by BobN » 21 Oct 2017, 06:07

Doug,

I tried and or verified the settings/options you suggested to no avail. So, I removed Log4OM cleaned up all file residue and cleaned the registry. I downloaded 1.30 again and installed the application following pages 9 to 27 as well as page 182 in support of JTAlertX/WSJT-X. Version 2.10.3 of JTAlert and version 1.8.0-rc3 of WSJT-X.

The result is the same. It seems that when WCF starts it does not start Log4OmCommunictor. I have been unable to determine why it fails to start.

More ideas?

BTW, I did try to setup the account as AK5U but it appears that it was already in use and I have been unable to get an email to reset the password. I think I used ak5u@arrl.net for email but I have no clue as to the PW I setup.

Thank you for the assistance,
Bob AK5U

User avatar
G4POP
Moderator
Posts: 4391
Joined: 21 Jan 2013, 15:55
Location: Burnham on Crouch, Essex UK

Re: CONNECT TCP Failing to connect

Post by G4POP » 21 Oct 2017, 07:10

Sounds like you did not install by right clicking the install file and selecting 'Run as an Administrator'
73 Terry G4POP

User avatar
G4POP
Moderator
Posts: 4391
Joined: 21 Jan 2013, 15:55
Location: Burnham on Crouch, Essex UK

Re: CONNECT TCP Failing to connect

Post by G4POP » 21 Oct 2017, 07:19

BTW, I did try to setup the account as AK5U but it appears that it was already in use and I have been unable to get an email to reset the password. I think I used ak5u@arrl.net for email but I have no clue as to the PW I setup.
I have sent you a temporary password by email for user account AK5U please change it next time you log into the AK5U account
73 Terry G4POP

BobN
Novice Class
Posts: 3
Joined: 19 Oct 2017, 19:25

Re: CONNECT TCP Failing to connect

Post by BobN » 21 Oct 2017, 21:25

Terry,

Removed the app, all files and registry settings for Log4OM and OmniRig. Followed your suggestion and installed L4OM using Run as Administrator. Followed setup pages 9 to 27. Same result.

One correction I need to report. Communicator is starting. TCP Connection is what does not start. And I assume that since it did not start, the icon for the Communicator is not placed in the Systray nor the Windows Toolbar.

Other possibilities?

Bob AK5U

PS - AK5U account is working. Thank you again.

AK5U
New user
Posts: 1
Joined: 24 Sep 2017, 00:03
Location: North Texas

Re: CONNECT TCP Failing to connect

Post by AK5U » 22 Oct 2017, 05:03

Terry et all,

I figured out the problem. I found the log for each run. I saved the current log and restarted Log4OM. Everything was good down to WCF Management: RunServices Started. I am inserting the few lines involved. I did a "netstat -ano" and found that PID 2728 was using TCP port 8081. In task manager I found that PID belonged to McAfee Common Services. I have the McAfee Agent and VSE installed on both systems which are failing.

I have changed TCP ports to 8084 and 8085 in WCF and set port 8085 in the Communicator. Two green in the middle.

Thank you for all the support. 73,
Bob AK5U

2017-10-22 03:31:37.3561 INFO: WCFManagement: RunServices starting with path
2017-10-22 03:31:37.3801 INFO: WCFManagement: Opening
2017-10-22 03:31:37.8691 INFO: WCFManagement: Opened
2017-10-22 03:31:37.8721 INFO: WCFManagement: RunServices STARTED
2017-10-22 03:31:37.8941 INFO: TCPServer: Closing TCP Connection [RESET LISTENING SOCKET]...
2017-10-22 03:31:37.9021 INFO: TCPServer: Closing TCP Connection [RESET LISTENING SOCKET]...
2017-10-22 03:31:37.9031 ERROR: *** TCPServer: Error creating listening socket on port 8081: [SocketException] Only one usage of each socket address (protocol/network address/port) is normally permitted

User avatar
W7DRM
Moderator
Posts: 480
Joined: 19 Feb 2014, 20:44

Re: CONNECT TCP Failing to connect

Post by W7DRM » 22 Oct 2017, 20:49

Hi Bob,

Very good troubleshooting on your part! You obviously know your way around a computer! FB!

73,
Doug - W7DRM

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest