Club Log Upload Options Not Explained

Need help? - Post here and we will find a solution for you.
User avatar
G4POP
Log4OM Alpha Team
Posts: 6381
Joined: 21 Jan 2013, 14:55
Location: Burnham on Crouch, Essex UK

Re: Club Log Upload Options Not Explained

Post by G4POP » 04 Jul 2018, 06:37

Imported from where?
From the program that created the log entry in it's own log file - WSJT-X - an FT8 contact

How?
Using the built-in adif import function in Log4OM.
WSJT-X does not record the Clublog status in its ADIF file so there is nothing for Log4OM to import, resulting in empty fields saved to the Log4OM logbook. See the WSJT-X ADIF file below, do you see a Clublog field?

Capture.JPG
Capture.JPG (81.42 KiB) Viewed 1446 times

TIP:
There is a better way to interface WSJT directly to Log4OM using JTAlert - See the user guide for JTAlert
73 Terry G4POP

User avatar
G4POP
Log4OM Alpha Team
Posts: 6381
Joined: 21 Jan 2013, 14:55
Location: Burnham on Crouch, Essex UK

Re: Club Log Upload Options Not Explained

Post by G4POP » 04 Jul 2018, 06:50

N5INP wrote:
03 Jul 2018, 22:45
Problem -

I selected one record to upload to see if the club log fields would be set to something (I expected "Y") after the upload. The upload appeared to do something because I got a message "Running Wait". That is all I saw. But when I checked the Club Log field it did not contain a "Y" or any other character for the record I just uploaded.

Before you ask - yes my name and password for Club Log are correct in Log4OM.

OK so I thought maybe since that record would be a dupe I get no field filled in so I tried it again with a new record (my FT8 contact with KH1/KH7Z) that has not been imported to Club Log any other way (it does not yet exist there). But the same thing happened - no character is put in the Club Log upload status OR date. Also the contact does not show up in my Club Log data. Did it upload or not? If Log4OM encountered an error in uploading it sure doesn't display any indication of that.

Did you refresh the window by clicking search with the 'Y' filter engaged?

I assume it was tested so what I'm guessing now is that I am not doing something that must appear as obvious to the developers but not so obvious to the average user?

This, as with all new Log4OM functions, was tested by our Alpha Testers, Beta testers and in the many months since we introduced it by the thousands of users that have downloaded the software.

As far as I can remember there have been no issues reported, with or without 'Added verbage in the user guide' and I also use the function on a daily basis.

What version of Log4OM are you using?

If you wish you can send me a support request as detailed here http://www.log4om.com/log4om-support/ but please include the ADIF file of your Log4OM logbook.
73 Terry G4POP

User avatar
N5INP
Old Man
Posts: 125
Joined: 12 Jan 2014, 00:24
Location: Fort Worth, TX
Contact:

Re: Club Log Upload Options Not Explained

Post by N5INP » 04 Jul 2018, 11:39

G4POP wrote:
04 Jul 2018, 06:50
Did you refresh the window by clicking search with the 'Y' filter engaged?
Yes I did. Before I make any posts like this I try many times to get it to work, and I read the manual. It doesn't work here for me, I don't know why, so I'm continuing to try to get answers.
This, as with all new Log4OM functions, was tested by our Alpha Testers, Beta testers and in the many months since we introduced it by the thousands of users that have downloaded the software.
Yes I am sure, but as I said it doesn't work on my computer system.
As far as I can remember there have been no issues reported, with or without 'Added verbage in the user guide' and I also use the function on a daily basis.
Now there is one though ...
What version of Log4OM are you using?
1.33.1.0
If you wish you can send me a support request as detailed here http://www.log4om.com/log4om-support/ but please include the ADIF file of your Log4OM logbook.
OK I will be doing that today, thanks.

User avatar
N5INP
Old Man
Posts: 125
Joined: 12 Jan 2014, 00:24
Location: Fort Worth, TX
Contact:

Re: Club Log Upload Options Not Explained

Post by N5INP » 04 Jul 2018, 12:53

Where am I supposed to send the support file Log4OM created? In the box it says -

"Please send it to a developer or support team member"

How?

What email address?

What PM?

I can neither PM Terry or find any email address listed to send the file.

User avatar
G4POP
Log4OM Alpha Team
Posts: 6381
Joined: 21 Jan 2013, 14:55
Location: Burnham on Crouch, Essex UK

Re: Club Log Upload Options Not Explained

Post by G4POP » 04 Jul 2018, 12:57

You could lookup my call on QRZ the email address is there but for speed its g4pop (AT) arrl.net where the (AT) represents @
73 Terry G4POP

User avatar
N5INP
Old Man
Posts: 125
Joined: 12 Jan 2014, 00:24
Location: Fort Worth, TX
Contact:

Re: Club Log Upload Options Not Explained

Post by N5INP » 04 Jul 2018, 13:12

G4POP wrote:
04 Jul 2018, 12:57
You could lookup my call on QRZ the email address is there but for speed its g4pop (AT) arrl.net where the (AT) represents @
OK file sent.

User avatar
G4POP
Log4OM Alpha Team
Posts: 6381
Joined: 21 Jan 2013, 14:55
Location: Burnham on Crouch, Essex UK

Re: Club Log Upload Options Not Explained

Post by G4POP » 04 Jul 2018, 13:31

Found your issue was as follows, not a Log4OM bug

1. You have not installed Log4OM to run as an administrator
2. You have an incorrect email address in the Clublog field of the Log4OM/Options/External logs/Clublog email address field

I corrected the email address and upload worked immediately and the QSO was marked Y and the date inserted in the Clublog status and date fields
73 Terry G4POP

User avatar
N5INP
Old Man
Posts: 125
Joined: 12 Jan 2014, 00:24
Location: Fort Worth, TX
Contact:

Re: Club Log Upload Options Not Explained

Post by N5INP » 04 Jul 2018, 14:48

G4POP wrote:
04 Jul 2018, 13:31
Found your issue was as follows, not a Log4OM bug

1. You have not installed Log4OM to run as an administrator
2. You have an incorrect email address in the Clublog field of the Log4OM/Options/External logs/Clublog email address field

I corrected the email address and upload worked immediately and the QSO was marked Y and the date inserted in the Clublog status and date fields
Club Log does not require an email to log in, you can only use a name and password, I just checked, I logged out and back in with a username and password ONLY, so the email is not part of the problem.

Also, it is true that Log4OM was not installed as Administrator, but in the section on this issue in the manual, it does not state that the upload will not work if Log4OM is not installed as an administrator. Even elsewhere in the manual, which I reviewed for this issue again, it simply states that some functions will not work, it does not state WHICH functions do not work if not installed as admin.

And another issue, as I wrote Terry in an email -

Log4OM does NOT give any indication of an error when the upload fails, all it displays is a message that a process is running - wait, doesn't that strike anyone as strange? If it can't upload then it should present the user with an error message "Error upload failed wrong username or password". This would be logical.

If it presented an error, then the user would be able to help himself more at that point armed with information that the login failed for a specific reason. If no error is displayed, then why would the user expect that an error occurred - any error at all? As it is it does not show an error. I am presenting this as a suggestion.

So I will thank Terry for his valuable time and I enjoy the software, and hope that you realize that by users posting these types of issues you can improve either the manual and or software, not every solution is an obvious fix for the average user. I wouldn't spend all this time reporting these things if I wasn't a dedicated user!

User avatar
G4POP
Log4OM Alpha Team
Posts: 6381
Joined: 21 Jan 2013, 14:55
Location: Burnham on Crouch, Essex UK

Re: Club Log Upload Options Not Explained

Post by G4POP » 04 Jul 2018, 14:54

N5INP wrote:
04 Jul 2018, 14:48
G4POP wrote:
04 Jul 2018, 13:31
Found your issue was as follows, not a Log4OM bug

1. You have not installed Log4OM to run as an administrator
2. You have an incorrect email address in the Clublog field of the Log4OM/Options/External logs/Clublog email address field

I corrected the email address and upload worked immediately and the QSO was marked Y and the date inserted in the Clublog status and date fields
Club Log does not require an email to log in, you can only use a name and password, I just checked, I logged out and back in with a username and password ONLY, so the email is not part of the problem.

Also, it is true that Log4OM was not installed as Administrator, but in the section on this issue in the manual, it does not state that the upload will not work if Log4OM is not installed as an administrator. Even elsewhere in the manual, which I reviewed for this issue again, it simply states that some functions will not work, it does not state WHICH functions do not work if not installed as admin.

And another issue, as I wrote Terry in an email -

Log4OM does NOT give any indication of an error when the upload fails, all it displays is a message that a process is running - wait, doesn't that strike anyone as strange? If it can't upload then it should present the user with an error message "Error upload failed wrong username or password". This would be logical.

If it presented an error, then the user would be able to help himself more at that point armed with information that the login failed for a specific reason. If no error is displayed, then why would the user expect that an error occurred - any error at all? As it is it does not show an error. I am presenting this as a suggestion.

So I will thank Terry for his valuable time and I enjoy the software, and hope that you realize that by users posting these types of issues you can improve either the manual and or software, not every solution is an obvious fix for the average user. I wouldn't spend all this time reporting these things if I wasn't a dedicated user!
True Clublog does not require your email to log into the website but it does for automated uploads via their API it's part of their security protection. Some sites also require either that or a unique API code as in the case of QRZ automated uploads.

LOTW of course not only require a user name and password they only accept a signed and encrypted file generated by Tqsl using a verified certificate so these levels of security are far from unusual.

If you don't see a confirmation that the upload is qued at Clublog then it failed and is recorded in the log file (Help/show log)

Usually failure to load a log after an update is due to the log being stored in a read only directory and the program not being run as an administrator.

Thank you for your input and dillegence

As you say you now have it working so move on!
73 Terry G4POP

User avatar
N5INP
Old Man
Posts: 125
Joined: 12 Jan 2014, 00:24
Location: Fort Worth, TX
Contact:

Re: Club Log Upload Options Not Explained

Post by N5INP » 04 Jul 2018, 17:54

Nope - it's not working again and I made no changes whatsoever at all to any settings.

I tried to upload another record as a test and I got no changes to the club log upload status in log4om so I checked the log file. I sent the log file to Terry, because it's a doozy of arcane computer text that I wouldn't have a clue how to interpret.

I'm going to my brother's for the 4th to eat hamburgers now, I need a break from this. I'll be back later today or tomorrow for more troubleshooting.

:|

Post Reply