User Profile Problem

Need help? - Post here and we will find a solution for you.
User avatar
G4POP
Moderator
Posts: 5758
Joined: 21 Jan 2013, 14:55
Location: Burnham on Crouch, Essex UK

Re: User Profile Problem

Post by G4POP » 09 Nov 2018, 14:33

Can't see anything in file you sent me so dealing with this by email with Lele but suspect it to be a computer issue on your local machine
73 Terry G4POP

ha5uk
Novice Class
Posts: 15
Joined: 09 Jan 2018, 13:54

Re: User Profile Problem

Post by ha5uk » 21 Nov 2018, 05:40

Not response from Lele so far and as problem still exists (busted config.xml at every second or third launch) some further details:
When it happens config.xml in appdata/roaming/LogOM is unreadable and seems empty, while unpzip this from the backup that was made the 'same time' makes logger start flawless. Hmm...

Checked HDD, every test is ok.
73, George / ha5uk

User avatar
IW3HMH
Site Admin
Posts: 2357
Joined: 21 Jan 2013, 14:20
Location: Quarto d'Altino - Venezia (ITA)
Contact:

Re: User Profile Problem

Post by IW3HMH » 21 Nov 2018, 10:24

It's something i can't understand.
It seems the serialization of the config file fails when it's written at the program end, and then will fail when config is loaded te next time.
So the issue on start is due to an erroneous save on previous exit

The same issue happens when deserializing tune reminders and regular expression filters

There are several issues also on external connections so it's something really strange and hard to find.

Can you kindly try using a PORTABLE version installation? Simply unpack portable version somewhere on your hard disk (not in system folders or C:\ root folder and try using it as now? (you can point to the same database obviously)
I need to understand where the cause is and this should help. In the meantime i'm adding some logs on relevant functions

Thanks
Daniele Pistollato - IW3HMH

ha5uk
Novice Class
Posts: 15
Joined: 09 Jan 2018, 13:54

Re: User Profile Problem

Post by ha5uk » 21 Nov 2018, 12:33

Ok Lele, I know it's hard to find what causes it. One more thing: when config.xml at log4om's main folder is not readible while backup is all right, the secondary backup (made same time) is also corrupted.

Will try portabel version.
73, George / ha5uk

User avatar
IW3HMH
Site Admin
Posts: 2357
Joined: 21 Jan 2013, 14:20
Location: Quarto d'Altino - Venezia (ITA)
Contact:

Re: User Profile Problem

Post by IW3HMH » 27 Nov 2018, 10:23

Yes, it's a serialization issue
Daniele Pistollato - IW3HMH

Post Reply