Log4OM, WSJT-X and JT-Alert-X (with VSPE) problem

Need help? - Post here and we will find a solution for you.
Post Reply
User avatar
IU1CYF
New user
Posts: 2
Joined: 01 Jun 2016, 13:03

Log4OM, WSJT-X and JT-Alert-X (with VSPE) problem

Post by IU1CYF » 07 Oct 2018, 23:47

Hi,
i've searched a lot before writing about this problem i could not work around.
I'm using a Lenovo T430 with Windows 10 Professional 64 bit.

Last year i've used with only one COM port the following 3 programs succesfully: Log4OM, WSJT-X and JT-Alert-X.
I made some QSO and automagically it could be possible to write the QSO's in the Log4OM log file with just a click..

Now i've again some time to play with my ICOM 7300 and i tried again.

I've tried in two different ways :
1) using the same port (COM4) for all the software
2) creating with VSPE (Virtual Serial Port Emulator) a splitting COM5 port attached to the COM4 and using the COM5 as explained in the manual in the pages 184 and following.

Unfortunatelly both was without success..

I try to explain what i've made for the point 2:

My Icom is connected through COM4:

Image


First i've create COM 5 virtual port (i've tried with different speed 9600,19200...115200 but the result are always KO).
connected to the COM4 that permit to connect multiple application to my Icom 7300..(in Teory..).

Image

Image

I've used Omnirig to set the parameter to connect to my Icom IC 7300 as following:

Image

This is the configuration of CW Skimmer (always with OmniRig so is the same as the previous one) :

Image

This is the configuration of WSJT-X:

Image

Until i use only one program at the same time it works fine.
As soon as i start the second one only one works.
The second one stop and inform me that it could not more talk to the Radio..

This is an example for WSJT-X informing me that it could no more talk to the radio:
Image

(i do not use HamLib ...i use Omnirig..but this is the message...).

Only CWSkimmer and Log4OM works fine together..
All the other combination do not work in my PC.

I've tried also on other 2 different laptop..a Lenovo T410 and a Fujitsu Life Book U747 both with Windows 10 Professional 64 bit.

May be it could be a user authorization problem..?
I've launched every program "executing as administrator" but i read in some forum that other people have had a similar problem.
you tried to launch with the admin privileges the software seem to agree (do not tell you any alert message) but it launch the program normally without the particular privilieges that could be necessary to perform the job...

I'm waiting for some suggestion and help...

thank you very much for the time you dedicate in helping me.

73
IU1CYF
73 de Paolo IU1CYF

User avatar
G4POP
Moderator
Posts: 5011
Joined: 21 Jan 2013, 15:55
Location: Burnham on Crouch, Essex UK

Re: Log4OM, WSJT-X and JT-Alert-X (with VSPE) problem

Post by G4POP » 08 Oct 2018, 06:30

You should not select your radio in WSJT select OMNIRIG RIG1 INSTEAD.

Of course ensure all programs are installed to 'Run as an administrator' by right clicking on the install file and selecting that menu item.

No VSP is required, just use OMNIRIG RIG1 in Wsjt and in JTalert set up logbook in settings to use Log4om to log to.
73 Terry G4POP

User avatar
IU1CYF
New user
Posts: 2
Joined: 01 Jun 2016, 13:03

Re: Log4OM, WSJT-X and JT-Alert-X (with VSPE) problem

Post by IU1CYF » 08 Oct 2018, 23:22

Thank you very much Terry,
now it's works fine!

I've tried some QSO in FT8 and all works really fine:

first it prompts asking me if i'd like to add the QSO

Image

and then it write all the information in the LOG4OM...

Image

thank you again for the time you have dedicated in helping me using this really fine piece of software.
73 de Paolo IU1CYF

User avatar
G4POP
Moderator
Posts: 5011
Joined: 21 Jan 2013, 15:55
Location: Burnham on Crouch, Essex UK

Re: Log4OM, WSJT-X and JT-Alert-X (with VSPE) problem

Post by G4POP » 09 Oct 2018, 07:34

No on the contrary I need to apologise to you for not deleting that section of the user guide because it is no longer relevant since WSJT included Omnirig support in their program.

I have deleted those pages and any new user guide download will not be so confusing.
73 Terry G4POP

Post Reply