EQSL/LOTW date errors

Yes, sometimes it happens... Please report any bugs here
Post Reply
vk7yum
Novice Class
Posts: 24
Joined: 06 Oct 2014, 08:40

EQSL/LOTW date errors

Post by vk7yum » 01 May 2017, 22:10

Hi

I think I've found a bug - but it might be a feature :D

I have Log4OM configured to auto upload eQSL. At the end of each session I upload to LoTW - which I have just done.
Current time here is 21:55UTC (07:55 local)

In the Recent QSO List <F8> I see (amongst others) EQSL Sent date and LOTW Sent date. Now is where it gets strange.
EQSL Sent date is 2/05/2017
LOTW Sent date is 1/05/2017

It appears EQSL is using local time but LOTW is using UTC time.

Is this the way it is supposed to work?

Cheers
David
VK7YUM

User avatar
G4POP
Moderator
Posts: 5806
Joined: 21 Jan 2013, 14:55
Location: Burnham on Crouch, Essex UK

Re: EQSL/LOTW date errors

Post by G4POP » 02 May 2017, 07:03

I think your Windows Date/Time setup could be incorrect because I cannot replicate the issue here, see below



Capture.JPG
Capture.JPG (51.81 KiB) Viewed 2873 times
73 Terry G4POP

User avatar
DF5WW
Log4OM Alpha Team
Posts: 1061
Joined: 02 May 2013, 09:49
Location: Kraam, Rhineland Palatinate, Germany
Contact:

Re: EQSL/LOTW date errors

Post by DF5WW » 02 May 2017, 11:46

Hi Terry,

think also that L4O is using the local time for setting the date on eQSL upload date. See attached screenshot.
There are two contacts after midnight local (UTC here 2 hrs behind) and the date for the new day (local) is
used. But not a problem so the date on the stored qso´s in the eQSL outbox is o.K.

B.t.w. my time settings on my PC are o.K.

So it looks like a "cosmetic" issue :D :D

df5ww1.png
df5ww1.png (7.46 KiB) Viewed 2870 times
Last edited by DF5WW on 06 May 2017, 11:58, edited 1 time in total.
73´s .. Juergen ... RedPitaya SDR 5 W, 20 mtr. indoor wireloop feeded with homemade ladderline (600 Ohms) ...

vk7yum
Novice Class
Posts: 24
Joined: 06 Oct 2014, 08:40

Re: EQSL/LOTW date errors

Post by vk7yum » 05 May 2017, 20:46

Hi Terry

Don't think its a Windoze thing .... I reckon you cannot reproduce it due to the fact your on UTC time? I'm not. Just for fun, set your Windoze machine at some other time zone (+UTC) and try again. I'm sure you will then be able to reproduce the "feature". :D

Cheers
David
VK7YUM

User avatar
G4POP
Moderator
Posts: 5806
Joined: 21 Jan 2013, 14:55
Location: Burnham on Crouch, Essex UK

Re: EQSL/LOTW date errors

Post by G4POP » 05 May 2017, 21:01

I will ask Lele to look at this
73 Terry G4POP

vk7yum
Novice Class
Posts: 24
Joined: 06 Oct 2014, 08:40

Re: EQSL/LOTW date errors

Post by vk7yum » 05 May 2017, 21:08

thanks Terry ;)

cheers
David
VK7YUM

User avatar
VK7XX
Old Man
Posts: 327
Joined: 24 Jan 2013, 04:07
Location: Planet Earth on Tasmania Island
Contact:

Re: EQSL/LOTW date errors

Post by VK7XX » 05 May 2017, 21:16

thanks for the heads up on this one David. I would not have noticed until reading about it. I looked back through my log and have hundreds of entries with this dual date feature.

73
John

User avatar
IW3HMH
Site Admin
Posts: 2378
Joined: 21 Jan 2013, 14:20
Location: Quarto d'Altino - Venezia (ITA)
Contact:

Re: EQSL/LOTW date errors

Post by IW3HMH » 13 May 2017, 15:30

Fixed in next release
Daniele Pistollato - IW3HMH

Post Reply