EME qso errors on LOTW confirmation via Log4OM

Yes, sometimes it happens... Please report any bugs here
Post Reply
ta2nc
Novice Class
Posts: 13
Joined: 02 Oct 2018, 17:14

EME qso errors on LOTW confirmation via Log4OM

Post by ta2nc » 17 Oct 2018, 21:53

Hello,
While importing LOTW confirmations from Log4OM
I noticed i was getting some errors as "not found" on my EME qsos.
I think, the mod that is kept on LOTW is JT65 instead of JT65B so, while downloading Log4OM can not find the qso information correct.

Maybe there should be something like JT65 = JT65B while downloading it from LOTW.

And second problem, on EME qsos the reports are not dB. Only "O" letter.
I can see it correct on my imported logs as "O" but on detail examination of the logs it seem like "+30"
I added the screenshot for it.

Regards
Attachments
2018-10-17_23-47-55.png
2018-10-17_23-47-55.png (11.09 KiB) Viewed 1058 times
2018-10-17_23-47-27.png
2018-10-17_23-47-27.png (6.38 KiB) Viewed 1058 times

User avatar
IW3HMH
Site Admin
Posts: 2236
Joined: 21 Jan 2013, 15:20
Location: Quarto d'Altino - Venezia (ITA)
Contact:

Re: EME qso errors on LOTW confirmation via Log4OM

Post by IW3HMH » 25 Oct 2018, 10:20

Sorry for delay
About "O" you can edit the configuration file adding that value to the list.

More details in my post here:
http://forum.log4om.com/viewtopic.php?f=5&t=3601

About mode you can use the same way on file "modelist.csv" (copy, rename, etc) as before...
but: actual modes in modelist.csv says:

...
JT65;JT65;JT65
JT65A;JT65A;JT65A;JT65A
JT65B;JT65B;JT65B;JT65B
...

That means you can correctly receive a JT65 mode and Log4OM will use/mark it as JT65 correctly (in ADIF too)
so it's strange you cannot get the correct mode from LOTW download (provided you have saved mode as JT65 in your log) as Log4OM, matching LOTW, is strictly use mode and doesn't allow "guessing" or defaults as modes are not fully interchangeable (and grouping them in block with default mapping from LOTW is out of scope)
Daniele Pistollato - IW3HMH

ta2nc
Novice Class
Posts: 13
Joined: 02 Oct 2018, 17:14

Re: EME qso errors on LOTW confirmation via Log4OM

Post by ta2nc » 30 Oct 2018, 18:02

Hello Daniele,
I googled some and found that..
lotw uploading automatically converts all JT65x qso's to JT65 even they are JT65B on original adif file.
So while downloading it sends JT65 confirmation, not JT65B as it is on Log4OM. And thats why Log4OM does not allow to confirm this qso.

So is it possible to pass this problem with modifying modelist.csv?
If so how?

ta2nc
Novice Class
Posts: 13
Joined: 02 Oct 2018, 17:14

Re: EME qso errors on LOTW confirmation via Log4OM

Post by ta2nc » 14 Nov 2018, 09:55

I wrote to LOTW developers about this..
This is the answer i got from W4TV

he software may display them as different modes but in fact they are
different *SUB MODES*. If ADIF were fully consistent there would be
a very limited number of "MODES" - CW, AM, (SSB,) FSK, PSK, MFSK and
NPSK. All other "modes" are really submodes that are distinguished
by the data encoding and error correction.

Mode is defined by modulation:
CW - on/off keyed telegraphy
AM - amplitude modulated voice with or without a carrier,
single, double, independent or vestigial sideband
FSK - frequency shift keying (1 of 2 tones)
PSK - phase shift keying
MFSK - multiple tone frequency shift keying (1 of n tones)
nPSK - multiple PSK carriers (e.g. COFDM)

Some "sub modes" have "mode" status for historical reasons *but*
ADIF have made several effort to "clean up" the number of spurious
modes in the past and needs to do so again.

Logging software if free to display Mode/Submode or just Submode
to the user but should always export the data in Mode/Submode format
for interchange purposes.


From this.. I understand that somehow, log4om does not accept mode overwrites submode on confirmation download from LOTW:

Post Reply