Error when downloading from LoTW while communicator running

Yes, sometimes it happens... Please report any bugs here
Post Reply
Novice Class
Posts: 9
Joined: 08 Feb 2016, 21:23

Error when downloading from LoTW while communicator running

Post by VE6EFR » 03 Sep 2017, 17:45

I was having an issue with my log disappearing after downloading from LoTW. I could upload without a problem, but any time I would download confirmations into Log4OM my log would be gone. It would show 0 records found and the only way I could get them back was to restore from a backup. While this worked, it would never allow me to update the LoTW Received Date column.

I believe the issue was caused by having communicator running and talking with JTAlert and WSJT-X. As long as communicator isn't running, I can download the confirmations without a problem and everything works as it should. But once communicator is running again, if I try to download from LoTW without making sure communicator is closed first the error returns and my log once again shows 0 records found and I have to restore from a backup.


User avatar
Posts: 4732
Joined: 21 Jan 2013, 15:55
Location: Burnham on Crouch, Essex UK

Re: Error when downloading from LoTW while communicator running

Post by G4POP » 03 Sep 2017, 22:03

If JTAlert was running then it will be accessing your database and this could cause the issue

I have the communicator running all the time and my LOTW downloads are faultless and touch wood I have never lost a database
73 Terry G4POP

User avatar
Posts: 501
Joined: 19 Feb 2014, 20:44

Re: Error when downloading from LoTW while communicator running

Post by W7DRM » 05 Oct 2017, 22:16

I just read this error report, and it somewhat matches what has happened to me twice in the last month. The last time was today. Right after downloading from LotW, it occurs. But I found it is not really a corrupt database, but rather Windows (Win 7) for some reason blocks that SQLite file name from being opened - so it shows 0 records, and NOT CONNECTED in the lower right corner of the Log4OM main window. I cannot open the log in Log4OM or using SQLite Manager Firefox plugin.

I have found two workarounds for it – restart Windows, or rename the SQLite file to another name. Then I am once again able to open the log in Log4OM.

I have not tried to do this with Communicator shut down. May try. But this has happened with WSJT-X and JTAlert running.

Doug - W7DRM

Advanced Class
Posts: 39
Joined: 07 Nov 2015, 16:41

Re: Error when downloading from LoTW while communicator running

Post by N6VH » 06 Oct 2017, 20:33

This has happened to me recently, as well. It just started in the last few weeks. I am using version 1.30 and the latest version of Win 10. Communicator is always running when Log4OM is. One workaround I have found is to open a different database, and then reopen the original one.


Jim N6VH

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests