Incorrect date: LOTW Sent Date

Need help? - Post here and we will find a solution for you.
Post Reply
G4IUA
Novice Class
Posts: 22
Joined: 15 Apr 2014, 20:20

Incorrect date: LOTW Sent Date

Post by G4IUA » 10 Nov 2018, 17:06

I've just noticed that the LOTW Sent Date shows incorrectly, e.g. today's date shows as 10/11/20 (today is 10th Nov 2018). This applies to every QSO going back many years and I'm pretty sure it has only just started today. Only the year is incorrect; the day and month are OK and all report DD/MM/20. LOTW Received Date and QSO Date are OK, and the date reported by Win 10 is correct.
Log4om v1.34.0.0.

Jeff - G4IUA

User avatar
G4POP
Moderator
Posts: 5096
Joined: 21 Jan 2013, 15:55
Location: Burnham on Crouch, Essex UK

Re: Incorrect date: LOTW Sent Date

Post by G4POP » 10 Nov 2018, 17:12

Firstly what version of Log4om are you using? This information is always required.

The date and time used on Log4om is derived from your Windows pc date, time and regional settings, we don't create the time and date in the code!

The only other way the date or time could be incorrect would be if it was in an incoming QSO from and external program like Fldigi or WSJT etc
73 Terry G4POP

G4IUA
Novice Class
Posts: 22
Joined: 15 Apr 2014, 20:20

Re: Incorrect date: LOTW Sent Date

Post by G4IUA » 10 Nov 2018, 18:59

Thanks Terry. Actually I did show the version of Log4OM: 1.34.0.0

That's odd as the Windows time and date are correct. It’s especially odd as all the LOTW Sent Dates show 2020 as the year, even for QSOs going back years. Although I usually run the latest versions of WSJT-X and JTAlert I specifically didn’t run these after a reboot so Log4OM isn’t receiving wrong data from them, and in any case surely that would only cause issues with new QSOs and not historical ones? The top Q is a dummy one just to show that this happens with only Log4OM running and not WSJT-X or FLDigi as you suggested. Any ideas?

Jeff – G4IUA
Capture.JPG
Capture.JPG (86.28 KiB) Viewed 146 times

User avatar
G4POP
Moderator
Posts: 5096
Joined: 21 Jan 2013, 15:55
Location: Burnham on Crouch, Essex UK

Re: Incorrect date: LOTW Sent Date

Post by G4POP » 10 Nov 2018, 19:28

Ehr Try making the LOTW date sent column wider, use the layout facility.

A picture was worth a thousand words Hi
73 Terry G4POP

G4IUA
Novice Class
Posts: 22
Joined: 15 Apr 2014, 20:20

Re: Incorrect date: LOTW Sent Date

Post by G4IUA » 10 Nov 2018, 19:49

Ah! How embarrassing! Thanks Terry. I can't believe I overlooked something so obvious!

Jeff

User avatar
G4DWV - Guy
Old Man
Posts: 370
Joined: 11 Sep 2014, 17:02

Re: Incorrect date: LOTW Sent Date

Post by G4DWV - Guy » 18 Nov 2018, 12:39

Jeff or Terry,

What was the issue in the end?

Cheers
You've never known happiness until you're married; but by then it is too late.

User avatar
G4POP
Moderator
Posts: 5096
Joined: 21 Jan 2013, 15:55
Location: Burnham on Crouch, Essex UK

Re: Incorrect date: LOTW Sent Date

Post by G4POP » 18 Nov 2018, 14:20

G4DWV - Guy wrote:
18 Nov 2018, 12:39
Jeff or Terry,

What was the issue in the end?

Cheers
As I said above he had the column width set too narrow which chopped off the last 2 digits, look at his screen shot!
73 Terry G4POP

User avatar
G4DWV - Guy
Old Man
Posts: 370
Joined: 11 Sep 2014, 17:02

Re: Incorrect date: LOTW Sent Date

Post by G4DWV - Guy » 18 Nov 2018, 18:03

Hi Terry,

I was puzzled as there seemed to be more than enough room for an extra "18" in the screenshot.

Cheers

Guy
You've never known happiness until you're married; but by then it is too late.

Post Reply