Omnirig with Icom 7300

Here we will provide support for developers working on integration
User avatar
W2MJP
Advanced Class
Posts: 38
Joined: 22 Dec 2016, 01:40

Omnirig with Icom 7300

Post by W2MJP » 04 Dec 2018, 01:40

Hello Everyone
First things first to the log4om team. Great job. Now for a question that probably has been asked before but I can’t find a answer. I can not get the Icom 7300 to communicate with the log4om log using omnirig. I installed the latest version on log4om and omnirig. When restarting the log4om program after everything installed. I followed the setting in cat control added the rig using the correct comm port. But I don’t get anything else, no communication between the rig and log4om. Is there a video on YouTube? I watched a few but they don’t help. Any advice is appreciated. Thank you.
Mike
Mike__W2MJP

User avatar
KI5IO
Old Man
Posts: 106
Joined: 16 Aug 2015, 17:30

Re: Omnirig with Icom 7300

Post by KI5IO » 04 Dec 2018, 02:34

Do a search for: icom 7300 setup Under the User Support section. Several threads come up and one might provide a clue for you.
73 - Nolan Kienitz - KI5IO
Plano, TX

User avatar
G4POP
Moderator
Posts: 5159
Joined: 21 Jan 2013, 15:55
Location: Burnham on Crouch, Essex UK

Re: Omnirig with Icom 7300

Post by G4POP » 04 Dec 2018, 13:23

W2MJP wrote:
04 Dec 2018, 01:40
Hello Everyone
First things first to the log4om team. Great job. Now for a question that probably has been asked before but I can’t find a answer. I can not get the Icom 7300 to communicate with the log4om log using omnirig. I installed the latest version on log4om and omnirig. When restarting the log4om program after everything installed. I followed the setting in cat control added the rig using the correct comm port. But I don’t get anything else, no communication between the rig and log4om. Is there a video on YouTube? I watched a few but they don’t help. Any advice is appreciated. Thank you.
Mike
The usual questions

1. Did you install the Icom USB driver BEFORE connecting the 7300 to your computer
2. Did you install BOTH Omnirig and Log4om in accordance with our Quick Start guide page 1, user guide page 9 and YouTube log4om quick start tutorial to 'Run as an administrator'
73 Terry G4POP

User avatar
W2MJP
Advanced Class
Posts: 38
Joined: 22 Dec 2016, 01:40

Re: Omnirig with Icom 7300

Post by W2MJP » 04 Dec 2018, 16:02

Hello Terry
Thanks for the response. Yes I have the usb drivers installed and implemented as I already have ft8 running. I did follow the instructions mentioned in the quick start guide. I installed omnirig from dx atlas, then updated and downloaded log4om. I then opened log4om and went to the proper settings and applied omnirig in the cat control and saved the setting. After that I went into the headset settings and set up rig info. I do not get the green light as I am suppose to. What should I try next?
Thank you.
Mike__W2MJP

User avatar
G4POP
Moderator
Posts: 5159
Joined: 21 Jan 2013, 15:55
Location: Burnham on Crouch, Essex UK

Re: Omnirig with Icom 7300

Post by G4POP » 04 Dec 2018, 16:38

Mike sorry to seem pedantic but did you install WSJT, Omnirig and Log4om as instructed in our guides and tutorials..

I.e
By right clicking the install exe files and selecting 'Run as an administrator' ?????

Unless you do that Omnirig will not multi thread and you have SNAFU!
73 Terry G4POP

User avatar
W2MJP
Advanced Class
Posts: 38
Joined: 22 Dec 2016, 01:40

Re: Omnirig with Icom 7300

Post by W2MJP » 05 Dec 2018, 23:38

Hi Terry
Yes I tried what you had posted in your last reply and opened both wsjt and Log4OM using Administrator and exe file were installed. After I did that the radio went into transmit mode, and still no cat connection. Do I have to change settings in the icom 7300? Yes I followed you tuturiol and quick guide. Thanks.
Mike__W2MJP

User avatar
G4POP
Moderator
Posts: 5159
Joined: 21 Jan 2013, 15:55
Location: Burnham on Crouch, Essex UK

Re: Omnirig with Icom 7300

Post by G4POP » 05 Dec 2018, 23:50

Forgetting wsjt so without it running! Is Log4om connecting ok to your radio using Omnirig?

What interface are you using?
73 Terry G4POP

User avatar
W2MJP
Advanced Class
Posts: 38
Joined: 22 Dec 2016, 01:40

Re: Omnirig with Icom 7300

Post by W2MJP » 08 Dec 2018, 12:36

Hi Terry
Yes. I opened by right clicking and running as Admin. Still no luck. No the radio does not connect with omnirig no green light for cat. Windows 10
Mike__W2MJP

User avatar
G4POP
Moderator
Posts: 5159
Joined: 21 Jan 2013, 15:55
Location: Burnham on Crouch, Essex UK

Re: Omnirig with Icom 7300

Post by G4POP » 08 Dec 2018, 13:11

W2MJP wrote:
08 Dec 2018, 12:36
Hi Terry
Yes. I opened by right clicking and running as Admin. Still no luck. No the radio does not connect with omnirig no green light for cat. Windows 10
Please again have you tried running Log4om without WSJT or any other programs running???
73 Terry G4POP

User avatar
W2MJP
Advanced Class
Posts: 38
Joined: 22 Dec 2016, 01:40

Re: Omnirig with Icom 7300

Post by W2MJP » 08 Dec 2018, 13:34

Yes
Mike__W2MJP

Post Reply