No PTT with FLDIGI

4Z1ZV
Advanced Class
Posts: 30
Joined: 05 Dec 2015, 09:23

No PTT with FLDIGI

Post by 4Z1ZV » 10 Apr 2020, 20:51

Hello,

Following a live internet lecture I delivered this week I got some feedback and tried to duplicate issues.

Most functions I tested works great including integration with WSJT-X and most function of FLDIGI.

Tested configuration:
LOG4OM2 2.4.0.0
Omnirig 1.19
Fldigi 4.1.11
xml-rpc communication as per manual.

However PTT by FLDIGI (which is critical) and Xcvr Frequency/Mode setting by fldg (not critical) not working at all.

Went over forums/reports - some other hams reporting same.

Made the following tests:

1. Switched from IC7300 to IC7100 - Same
2. Swapped to other Omnirig .ini file - Same
3. Moved back from fldg4.1.11 to much older versions that worked for me with LOG4OM1 (has specific check box to enable xml-rpc) - Same
4. Tried to play with RTS/DTR and time delays - Same
5. Tested with Hamlib - works OK including two way frequency.

Looks like port setting are OK as LOG4OM2 --> Fldigi works fine (Frequency, Mode, Call)
Communication from Fldigi --> LOG4OM2 does not work for all functions.

What other test I can perform to support solving this critical issue ?
4Z1ZV

4X1ST
Novice Class
Posts: 12
Joined: 27 Aug 2019, 19:57

Re: No PTT with FLDIGI

Post by 4X1ST » 11 Apr 2020, 04:56

Hey Zvika,

It isn't a Log4OM problem. The sad fact is that FLDigi doesn't work with OmniRig. If it did, life would be much easier.

You *can* use FLRig to trigger the 7300's PTT and run the tuning. And then L4OM's FLDigi integration works ok, but you can't have WSJT-X open at the same time.

I suspect all this could be made to work together using a virtual COM port (COM0COM or something like that). But life's too short, and I'm not in a hurry to use PSK ;)

73
Tim.

4Z1ZV
Advanced Class
Posts: 30
Joined: 05 Dec 2015, 09:23

Re: No PTT with FLDIGI

Post by 4Z1ZV » 11 Apr 2020, 08:36

Hello Tim and the team....

Fldg did work for me with same configuration (LOG4OM1,OmniRig, IC7300) and for other hams with LOG4OM2.

Actually it gets the frequency and mode through LOG4OM using xml-rpc protocol which makes the Trxcv/OmniRig totally transparent.
This led me to believe that it has to do with something in the communication fldigi-<xml-rpc>->LOG4OM2-->Omnirig-<CAT>->IC7300.

I am sure the development team will be able to solve it.
Hope it will be this week so we can use it during HOLY LAND CONTEST on April 18.

Zvi
4Z1ZV

User avatar
DF5WW
Log4OM Alpha Team
Posts: 1614
Joined: 02 May 2013, 09:49
Location: Kraam, Rhineland Palatinate, Germany
Contact:

Re: No PTT with FLDIGI

Post by DF5WW » 11 Apr 2020, 09:21

Hello Zvi,

that don´t can work as long as Fldigi not can connect to Omnirig. XML.rpc is telling the band/mode
information from Fldigi to Log4OM and backwards but if you have Omnirig connected FLdigi has no
PTT signal from it. That´s why Tim said you have control FLdigi via FLrig and use the xml.rpc to change
Data with Log4OM.

This means too that you can´t run Log4OM/FLdigi/WSJT-X (or derivates) togehther. Only one CAT
connection can handle your transceiver. Tell the Fldigi programmer that he should be give the
Software Omnirig support and all is fine.

;) ;)
73´s .. Juergen ... ALT-512 SDR (10W) , 50 m random wire at CG-3000 autotuner, Ailunce HS2 (20W and 5W VHF/UHF) to LPDA´s and different vertical´s ...

4Z1ZV
Advanced Class
Posts: 30
Joined: 05 Dec 2015, 09:23

Re: No PTT with FLDIGI

Post by 4Z1ZV » 11 Apr 2020, 11:46

Hello All,

1. IT DOES WORK ON LOG4OM1 with same configuration, as well as some other hams reporting it works for them on older versions of LOG4OM2.
2. The flow of Freq/Mode is only from LOG4OM to fldg. In my case it does not work backwards.

This is why I suspect it has to do with the communication path from fldigi to LOG4OM2.

Zvi
4Z1ZV

4Z1ZV
Advanced Class
Posts: 30
Joined: 05 Dec 2015, 09:23

Re: No PTT with FLDIGI

Post by 4Z1ZV » 11 Apr 2020, 22:05

Just to make sure it is not a computer related issue, I installed LOG4OM 1 with same configuration of fldigi and omnirig.

Made only basic configuration and enabled fldigi in the communicator.

PTT WORKS... As expected.

Hope the above information is clear enough to help debugging it.
Will be more than happy to be the QA for workaround.

Zvi
4Z1ZV

4Z1ZV
Advanced Class
Posts: 30
Joined: 05 Dec 2015, 09:23

Re: No PTT with FLDIGI

Post by 4Z1ZV » 11 Apr 2020, 22:35

OK, I found an ugly work around but it does the job.

Install also Log4OM Ver 1.
Do basic configuration.
Enable COMMUNICATOR with inbound fldigi. Make sure that READ FROM FLDIGI box is checked.

This mechanism will enable PTT.

I guess this is also focusing the debug on the inbound channel fldigi-->Log4om-->omnirig


Zvi
4Z1ZV

DK9JC
Advanced Class
Posts: 65
Joined: 20 Jan 2019, 13:10
Location: Germany
Contact:

Re: No PTT with FLDIGI

Post by DK9JC » 28 Apr 2020, 22:41

I have the same problem:

Tested configuration:
LOG4OM2 2.5.0.0
Omnirig 1.19
Fldigi 4.1.12 (also checked: 4.1.08)
Rig: IC-7300

xml-rpc communication is OK.
QRG shown OK like in log4om and call from Log4OM also shown in FLDigi.

PTT does not trigger in FLDigi and I can not transmit any macro.

I wonder what can I do to trigger the PTT?

I have read the complete Log4OM manual and also the FLdigi resources.

PTT in Log4OM via keyboard shortcut works fine.

EDIT: I found only this way (virtual com port splitter: viewtopic.php?f=33&t=4379&hilit=cat+fld ... =10#p24473)
and here why it is needed now: viewtopic.php?f=33&t=4593&hilit=cat+fld ... =30#p25619

--> I don't need a further answer here.
73 de John, DK9JC (AK9JC stateside)
https://www.dk9jc.de

sq7bcn
Advanced Class
Posts: 38
Joined: 24 Sep 2017, 15:04

Re: No PTT with FLDIGI

Post by sq7bcn » 21 Oct 2020, 07:27

I have the same problem ic7300-Log4OM2-FLdig - PTT control does not work only in FLdigi.When I turn off LOG4OM2 it works.I checked different possibilities with FlRig, CAT (Rig), no change.LOG4OM1 worked fine, read forums and checked a lot of settings, unfortunately it doesn't work and I know a lot of people have this problem.

User avatar
G4POP
Log4OM Alpha Team
Posts: 7755
Joined: 21 Jan 2013, 14:55
Location: Burnham on Crouch, Essex UK

Re: No PTT with FLDIGI

Post by G4POP » 21 Oct 2020, 08:13

Have none of the 7300 owners read my detailed set up of Log4om and Fldigi?

As Jurgen said Fldigi make it hard to interface all features but with the 7300 it can be done
73 Terry G4POP

Post Reply