Flex Multiple Slices + Omnirig

V2 error reports
HI8SMX
Advanced Class
Posts: 34
Joined: 15 Jun 2019, 17:23

Flex Multiple Slices + Omnirig

Post by HI8SMX » 16 Jan 2020, 02:43

I have installed and configured V2 with no relevant issues and so far it was worth the wait...congrats!!!vThere is only one thing I haven't been able to do, and that is to populate the Qso info directly from WSJTX (I got to log directly from Wsjtx all right).

Here is the set up: I run a Flex 6300, with SmartSDR V3, Slice Master, Wsjtx 2.1. and Omnirig. When I open Log4OM it connects to Flex on COM4 and it works fine. But whenever I open Slicemaster to do Wsjtx on 1 or 2 slices, WSJTX takes Radio as Ham Radio Deluxe in both slices and assigns them Networks Server 7831 and 7832 respectively. If I choose Omnirig as radio then both slices become one and I loose the capability of operating 2 different bands/freq. These same ports (7831 an 7832) are assigned to the UDP Servers (instead of 2237). If I change them to 2237 they go back to 7831 and 7832.

As a result I cant assign UDP 2237 to JTMessage according to the Manual causing that no info is passed to Log4OM until the QSO is loged. No look up, no worked before, etc.

Therefore if I choose Omnirig on Wsjtx I loose the second slice, I have no info passed to Log4OM and cant use UDP 2237.

Please advice.

73,
Santiago HI8SMX
______________
73 de Santiago
HI8SMX
web: www.hi8smx.online
YouTube: HI8SMX
Twitter: @hi8smx
Instagram: hi8smx

User avatar
IW3HMH
Site Admin
Posts: 2680
Joined: 21 Jan 2013, 14:20
Location: Quarto d'Altino - Venezia (ITA)
Contact:

Re: Flex Multiple Slices + Omnirig

Post by IW3HMH » 16 Jan 2020, 12:20

Log4OM is not bounded to a specific port in any service.
If you can change the port in WSJT, simply tell Log4OM to listen to that port.
Port numbers are reported in the manual because they're the default but you can open UDP channels on port of your choice
Daniele Pistollato - IW3HMH

HI8SMX
Advanced Class
Posts: 34
Joined: 15 Jun 2019, 17:23

Re: Flex Multiple Slices + Omnirig

Post by HI8SMX » 16 Jan 2020, 13:43

IW3HMH wrote:
16 Jan 2020, 12:20
Log4OM is not bounded to a specific port in any service.
If you can change the port in WSJT, simply tell Log4OM to listen to that port.
Port numbers are reported in the manual because they're the default but you can open UDP channels on port of your choice
Thanks for replying. Indeed I was trying to set the UDP ports following WSJT's ports (7831 and 7832) but I get nothing on Log4Om. Some screenshots are below.

UDP INBOUND
Port: 7831
Name: WSJT DX CALL
Type: JT Message

And the same for 7832. Meanwhile 2333 for Login directly is working flawlessly.

I´m pretty sure is something on my end and not the program. Will keep investigating.

Thanks,

Santiago
Log4OM Connections.PNG
Log4OM Connections.PNG (47.04 KiB) Viewed 1487 times
WSJTX Reporting Config.PNG
WSJTX Reporting Config.PNG (83.18 KiB) Viewed 1487 times
______________
73 de Santiago
HI8SMX
web: www.hi8smx.online
YouTube: HI8SMX
Twitter: @hi8smx
Instagram: hi8smx

User avatar
IW3HMH
Site Admin
Posts: 2680
Joined: 21 Jan 2013, 14:20
Location: Quarto d'Altino - Venezia (ITA)
Contact:

Re: Flex Multiple Slices + Omnirig

Post by IW3HMH » 16 Jan 2020, 14:30

Enabling DEBUG (or TRACE) mode in HELP menu you can see if something is received, as everything is logged into program log (also accessible from HELP menu)
This greatly helps debugging and checking if something is arriving to Log4OM
Daniele Pistollato - IW3HMH

EI2GLB
Old Man
Posts: 102
Joined: 21 Jan 2013, 22:19

Re: Flex Multiple Slices + Omnirig

Post by EI2GLB » 16 Jan 2020, 19:19

I'm also having this problem, Logs the QSO's perfect just wont populate the entry window during the QSO,

not sure if this is anything to do with it,

16-Jan-20 7:17:32 PM * [#=zmWK4$oZeN8eoeD6RqBN2foU=][MoveNext][8 ms] : Error in ADIF import, returning empty log
[EXCEPTION] StartIndex cannot be less than zero.
Parameter name: startIndex

User avatar
IW3HMH
Site Admin
Posts: 2680
Joined: 21 Jan 2013, 14:20
Location: Quarto d'Altino - Venezia (ITA)
Contact:

Re: Flex Multiple Slices + Omnirig

Post by IW3HMH » 16 Jan 2020, 20:15

It seems you didn't received an ADIF string through the service that is made to receive adif strings.
Enable TRACE mode in HELP menu (default is INFO) and this will show you right after the issue what is the content of the received message.
It's not saved by default because you may receive very large files and TRACE mode is slowing down all activities.
Daniele Pistollato - IW3HMH

EI2GLB
Old Man
Posts: 102
Joined: 21 Jan 2013, 22:19

Re: Flex Multiple Slices + Omnirig

Post by EI2GLB » 16 Jan 2020, 20:23

That is on post 2237 which is logging the QSO's ok

port 2323 is used to populate the call entry window and I don't seem to be rxing anything from that port??

User avatar
G4POP
Log4OM Alpha Team
Posts: 7755
Joined: 21 Jan 2013, 14:55
Location: Burnham on Crouch, Essex UK

Re: Flex Multiple Slices + Omnirig

Post by G4POP » 16 Jan 2020, 20:26

EI2GLB wrote:
16 Jan 2020, 20:23
That is on post 2237 which is logging the QSO's ok

port 2323 is used to populate the call entry window and I don't seem to be rxing anything from that port??
Port is 2333 not 2323 and I just checked and it works for me both look up and QSO Add, with those settings, see screenshot

WSJT action.jpg
WSJT action.jpg (120.28 KiB) Viewed 1452 times
73 Terry G4POP

EI2GLB
Old Man
Posts: 102
Joined: 21 Jan 2013, 22:19

Re: Flex Multiple Slices + Omnirig

Post by EI2GLB » 16 Jan 2020, 20:53

I changed it to 2323 to make sure it was not a conflict on 2333

I reset everything and reconfigured LOG4OM and WSJT-X and it's working now,

Not sure why but it is,

Thanks
Trevor
EI2GLB

HI8SMX
Advanced Class
Posts: 34
Joined: 15 Jun 2019, 17:23

Re: Flex Multiple Slices + Omnirig

Post by HI8SMX » 16 Jan 2020, 21:56

Then I must be doing something terrible wrong on my end, because it´s not working for me.

I can log directly from Wsjtx thru port 2237, in both slices (A and B) opened by Slice Master. But when it comes to populate the QSO window I get nothing from Wsjtx. I ´ve tried changing udp ports but nothing seems to work. Because I open multiple instances of Wsjtx using Slice Master it assigns them UDP ports 7831 (slice A) and 7832 (slice B) and even if I change them they come back to those numbers.

Then I tried to create the udp connection (JT Message) using those 2 udp ports numbers, but I get no info sent to Log4Om. See my current configurations on pictures below. Please note that I cannot change the radios to Omnirig, because then I will loose the multiple slices capabilities of the Flex. I know that the reason must be related to the multiple slices.

73, Santiago
WSJTX Reporting Config.PNG
WSJTX Reporting Config.PNG (83.18 KiB) Viewed 1444 times
Wsjtx Slice A - B Radio Config.PNG
Wsjtx Slice A - B Radio Config.PNG (64.98 KiB) Viewed 1444 times
Wsjtx Slice A - B Reporting Config.PNG
Wsjtx Slice A - B Reporting Config.PNG (71.1 KiB) Viewed 1444 times
______________
73 de Santiago
HI8SMX
web: www.hi8smx.online
YouTube: HI8SMX
Twitter: @hi8smx
Instagram: hi8smx

Post Reply