JTalert and Log4OM version 2

General discussions V2
User avatar
IW3HMH
Site Admin
Posts: 2575
Joined: 21 Jan 2013, 14:20
Location: Quarto d'Altino - Venezia (ITA)
Contact:

Re: JTalert and Log4OM version 2

Post by IW3HMH » 26 Jan 2020, 10:20

By the way i have the same issue...
And i'm quite sure (you can trust me) that error message is not being raised by Log4OM 2

Unfortunately i don't have enough info about reasons this error is triggered on JTAlert, but it happens also when Log4OM is not running so it's hard to get it.
I have it both on WSJT and JTDX
Daniele Pistollato - IW3HMH

User avatar
sq9jxb
Advanced Class
Posts: 61
Joined: 14 Jan 2020, 16:00
Contact:

Re: JTalert and Log4OM version 2

Post by sq9jxb » 26 Jan 2020, 10:35

DF5WW wrote:
26 Jan 2020, 10:17
If you have not used MySql in Log4OM you have to do nothing. When installing normally all is set
to use SQlite. You have only to change in JTalert but if the setup window will not open there it
could be another problem. But it´s JTalert problem and not Log4OM. If this is reported by other
JTalert users on Lauries site i think he will be fix this. But you can try a fresh installation of JTa
so it could be possible that you have only a corrupt installation.


L4O.png

Hello Juergen

Yesterday I did several installation attempts and the effect was always the same.
It is reported to VK3AMA, because it's not only I who has such a problem.
If there was a problem then JT-Alert 2.15.7 Beta 0001 would not work and it works without a problem.
The problem is in JT-Alert - VK3AMA does not yet know what and recommends using the working version.

Regards
Log4OM 2.4 , JTDX 2.1.0.x64, Windows 10 x64
Yaesu FT-897D, Icom IC-735, Musb1017/Musb2232FK , ATU-150 , LDG-AT-200Pro
SGC PowerClear, EMU0202
.........................................
73!
Jan SQ9JXB

User avatar
sq9jxb
Advanced Class
Posts: 61
Joined: 14 Jan 2020, 16:00
Contact:

Re: JTalert and Log4OM version 2

Post by sq9jxb » 26 Jan 2020, 10:39

IW3HMH wrote:
26 Jan 2020, 10:20
By the way i have the same issue...
And i'm quite sure (you can trust me) that error message is not being raised by Log4OM 2

Unfortunately i don't have enough info about reasons this error is triggered on JTAlert, but it happens also when Log4OM is not running so it's hard to get it.
I have it both on WSJT and JTDX
Hello Danielle

As I described earlier, this is a JT-Alert problem, not Log4OM.
Version 2.15.7 Beta 0001 works for me.
We need to be patient until VK3AMA solves the problem

Regards
Log4OM 2.4 , JTDX 2.1.0.x64, Windows 10 x64
Yaesu FT-897D, Icom IC-735, Musb1017/Musb2232FK , ATU-150 , LDG-AT-200Pro
SGC PowerClear, EMU0202
.........................................
73!
Jan SQ9JXB

WA2SQQ
Old Man
Posts: 164
Joined: 16 Feb 2015, 20:13
Location: New Jersey US

Re: JTalert and Log4OM version 2

Post by WA2SQQ » 28 Jan 2020, 15:51

I have been following the JTALERT migration to LOG4OM since V2 was released. This was the only “issue” that introduced hesitation to installing V2. All appears to be working now. I’m wondering if there is a preferred upgrade path.
1. Should JTALERT be updated to the latest version before updating to V2?
2. When I install V2, will it automatically read any V1 config settings that were associated with V1 and JTALERT?
3. Are there any compelling reasons to run both LOG4OM V1 & V2, or does V2 seem stable enough to drop V1?

User avatar
G4POP
Log4OM Alpha Team
Posts: 6592
Joined: 21 Jan 2013, 14:55
Location: Burnham on Crouch, Essex UK

Re: JTalert and Log4OM version 2

Post by G4POP » 28 Jan 2020, 16:00

WA2SQQ wrote:
28 Jan 2020, 15:51

1. Should JTALERT be updated to the latest version before updating to V2?
Either way it does not matter
2. When I install V2, will it automatically read any V1 config settings that were associated with V1 and JTALERT?
No the structure is completely different, please refer to our user guide
3. Are there any compelling reasons to run both LOG4OM V1 & V2, or does V2 seem stable enough to drop V1?
Depends how trusting you are, I have been exclusively using V2 for several months but there is a simple interface between V1 and V2 that will keep V1 in synchronisation with V2 if your concerned - This again is fully documented in our user guide
73 Terry G4POP

WA2SQQ
Old Man
Posts: 164
Joined: 16 Feb 2015, 20:13
Location: New Jersey US

Re: JTalert and Log4OM version 2

Post by WA2SQQ » 29 Jan 2020, 18:46

Thanks Terry - I've been reading the manual and watching the videos. It is time well spent. Well written and easy to understand. Again, many thanks!

WB8AM
Novice Class
Posts: 10
Joined: 13 Jun 2019, 13:33

Re: JTalert and Log4OM version 2

Post by WB8AM » 29 Jan 2020, 21:24

Quick question. Page 136 of the instructions show that in WSJT settings the UDP server port is set to 2333. Also on the same page, the UDP_INBOUND, JT_MESSAGE connector in L4OM2 is unchecked. Is this correct?
Picture1.png
Picture1.png (166.04 KiB) Viewed 931 times

User avatar
W7DRM
Log4OM Alpha Team
Posts: 759
Joined: 19 Feb 2014, 19:44

Re: JTalert and Log4OM version 2

Post by W7DRM » 30 Jan 2020, 00:49

OM,

That unchecked setting was for use without JTAlert running. Sorry for the confusion. During testing we have many settings which are turned on/off as needed. Eventually I suspect we will clean up those examples. So no, that entry should not be checked and is not needed - assuming you are running JTAlert.

73,

Doug - W7DRM

IW3GCR
Novice Class
Posts: 14
Joined: 21 Jan 2018, 00:11

Re: JTalert and Log4OM version 2

Post by IW3GCR » 31 Jan 2020, 08:37

Good morning,
I too have the same problem with jtalert last version.
But if I try to go into the jtalert configuration I get the error:
Fatal error- MySql Start Failure-Program will now exit.

And with the previous V4 version of log4om everything worked.
I tried again, reinstalling previous jtalert and it works, but as soon as I install the last one, here is the error.

However, I must point out that I have kept both versions of log4om ie both v1 and v2.

Thank you

User avatar
G4POP
Log4OM Alpha Team
Posts: 6592
Joined: 21 Jan 2013, 14:55
Location: Burnham on Crouch, Essex UK

Re: JTalert and Log4OM version 2

Post by G4POP » 31 Jan 2020, 10:13

IW3GCR wrote:
31 Jan 2020, 08:37
Good morning,
I too have the same problem with jtalert last version.
But if I try to go into the jtalert configuration I get the error:
Fatal error- MySql Start Failure-Program will now exit.

And with the previous V4 version of log4om everything worked.
I tried again, reinstalling previous jtalert and it works, but as soon as I install the last one, here is the error.

However, I must point out that I have kept both versions of log4om ie both v1 and v2.

Thank you
This is an issue you should address to JTAlert, it is not a Loh4OM issue, I have heard of several cases of this problem
73 Terry G4POP

Post Reply