Icom 756 ProIII interface

Need help? - Post here and we will find a solution for you.
Post Reply
K5CKS
Advanced Class
Posts: 46
Joined: 15 Oct 2019, 21:26

Icom 756 ProIII interface

Post by K5CKS » 19 Oct 2019, 23:08

I am having a little problem with the Beta release of the Icom IC-756 ProIII interface. The problems I noticed are...
1. When I click on a cluster spot the frequency is changing but the Mode is remaining the same as it was. So if I am on 20M SSB and click on a spot that is 20M CW the rig will change frequency but stays in SSB instead of changing to CW.
2. When I click on a spot that has a QSX frequency it is not putting the 756 ProIII into split and setting the 2nd VHF Freq.
3. When I work a station Split it is not logging my transmit frequency from the second VFO but does log the Receive frequency as the "Transmit Freq".
Since DX4Win was working perfectly my guess is that there is something wrong with the command line or more likely I am doing something wrong :-)
Thanks Guys!
73,
Rory, K5CKS

User avatar
KI5IO
Log4OM Alpha Team
Posts: 441
Joined: 16 Aug 2015, 16:30

Re: Icom 756 ProIII interface

Post by KI5IO » 20 Oct 2019, 01:28

Rory,

I'll assume you are using OmniRig for the CAT control from Log4OM and your rig.

Couple things: Make sure both OmniRig and Log4OM are running with Admin privileges Make sure you also have the most recent version of OmniRig and the related rig "ini" files installed. Double check the rig ini file you have selected for use.

I think I recall reading here in the forum of some issues now and then with an OmniRig ini file for the Icom. Don't recall which version at this time. Don't recall details, but if you do a search I'm sure you will find a clue.
73 - Nolan Kienitz - KI5IO
Plano, TX

K5CKS
Advanced Class
Posts: 46
Joined: 15 Oct 2019, 21:26

Re: Icom 756 ProIII interface

Post by K5CKS » 20 Oct 2019, 14:02

I figured it out this morning after a couple of cups of coffee :-) All I needed to do was check the box to set Mode for a spot on the cluster. Works perfectly now.
Thanks & 73,
Rory, K5CKS

Post Reply