Cat Control not working with Yaesu FT767GX

Post Reply
Novice Class
Posts: 3
Joined: 01 Feb 2023, 17:23

Cat Control not working with Yaesu FT767GX

Post by G6TSJ »

I am trying to connect my Yaesu FT767GX to Log4OM2 in order to access the frequencency etc but I have not managed to get communications working and wondered if anyone can offer any advice.

Here is what I have done so far.
I watched a series of youtube videos by CT2JKO where he serviced a FT767GX and finished off testing the CAT interface with DXLab Suite Commander so I decided this was a good place to start.
I purchased a FT-Cable-3-USB from XGGcomms and connected it to my computer running Windows 10
I downloaded and installed DXLab Suite Commander and configured the comms as follows.
COM5 (the port used by the FT-Cable -3 indicated in device manager)
Baud 4800, No Parity, 2 stop bits, DTR off, RTS TX, Command interval 200ms, scan dwell 1
This configuration works fine and I can control the frequency / mode etc from commander and it will read back the values if I change the controls or frequency on the rig directly.
During operation the CAT light on the rig flashes at a rate of about 750ms

Having confirmed that the cable and comms work I proceeded to download and install LOG4OM 2 ver
I noted that OmniRig does not support the FT767GX so selected to use Hamlib.

Settings used were :-
Settings TAB
Hamlib, CAT delay 250ms
Hamlib TAB
Rig Model Yaesu FT767GX Stable, Port COM5, Baud 4800, 2 Stop bits, DCD None, Polling delay 2000
This results in a Generated paramater string :-
--model=1009 --rig-file=COM5 --serial-speed=4800 --port=4532 --set-conf=stop_bits=2 -Z
I then selected Connect / CAT/ Start CAT and the CAT light on the rig flashes twice and then goes off. During this time the CAT indicator in LOG4OM2 stays solid green and then turns off.
No frequency or other data is displayed just OFFLinE
If I repeat the above i.e. Connect / CAT/ Start CAT. I get the same results.

Next step was to install FLDigi to see if RIGCat would communicate but then discovered that RIGCat does not support the FT767GX. At this point I noted that Fldigi also supported HAMLib so I decided to look at the setup there.
I noticed that in FLDigi different parameters are exposed to the user so I proceeded to setup Hamlib and test it.
Settings used were:-
Rig Yaesu FT767GX Stable, Port COM5, Baud 4800, 2 Stop bits, Polling interval 250ms, Timeout 3000ms, write delay 50ms, Post write delay 5 ms
Suprisingly this setup worked and the frequency and mode data were displayed and were controllable, but the response was slower than commander.
Software versions were Fldigi 4.1.23, Hamlib 4.1

After doing a bit of research on rigctl I next modified the Log4OM2 Hamlib Used Parameter string to incorporate some of the additional parameters used in the hamlib 4.1 version used in FLDigi as below.
model=1009 --rig-file=COM5 --serial-speed=4800 --port=4532 --set-conf=stop_bits=2 --set-conf=timeout=3000 --set-conf=write_delay=50 --set-conf=post_write_delay=5 -Z
I tried this with and without the –port=4532 parameter used in the Generated paramater string as I could not find any details on what this parameter does.
Either way the results were the same as with the original generated parameter string, the CAT light on the rig flashes twice and then goes off with just OFFLinE displayed.

Between tests of different software I rebooted the PC to ensure no stray bits of software were running and grabbing the serial port.
I have now run out of ideas and I am hoping someone might be able to suggest why the hamlib 4.1 version communicates with the rig but the version used in Log4OM2 does not. I cannot find any information on the hamlib version incorporated in Log4OM2.

Sorry for the long post but I wanted to provide as much information as possible.

Phill, G6TSJ
Novice Class
Posts: 3
Joined: 01 Feb 2023, 17:23

Re: Cat Control not working with Yaesu FT767GX

Post by G6TSJ »

A quick update on some further tests.

I came across a YouTube video last night that guided me to another configuration window for hamlib in Log4OM2. This is accessed from Connect / CAT/ Show CAT interface and is the same as the one accessed through settings / program configuration / CAT interface but with the addition of a button marked “Open hamlib standalone” and to the side of it a green tick in another button.
I selected the button and a pop-up window appeared. You’re about to start hamlib as a standalone process. You should then connect to it as an existing instance.
I selected OK and the CAT indicator on the rig flashed 8 times before going out. An instance of rigctld.exe was now running and when I selected verbose in the debug option the command window showed that the rigctld software appeared to be interrogating the rig.
I then clicked on the green arrow button and after about 5 seconds communications started with the rig and LOG4OM2 was populated with the rig information.
The response time is slow however, if I click on a frequency digit the change appears at the rig in about 5 secs and then 5 secs later the value at LOG4OM is updated.
The green RX symbol is illuminated in the CAT screen together with the red TX symbol.
If I click on USB in the CAT Screen the Rig switches to CW mode and the CAT Screen illuminates the USB icon and the CW icon. Clicking on LSB at this point does nothing but selecting AM will get the rig and software back in sync. If it try clicking LSB at this point again nothing happens but if I select LSB on the rig the CAT Screen indicates it correctly.
I noticed that the green tick button in the hamlib connection window performs the same function as the Connect / CAT/ Start Cat option.

I am going to try and change some values in the parameter string next to see if I can improve the response time of hamlib and get it to an acceptable value.

Phill, G6TSJ
User avatar
Log4OM Alpha Team
Posts: 9992
Joined: 21 Jan 2013, 14:55
Location: Burnham on Crouch, Essex UK

Re: Cat Control not working with Yaesu FT767GX

Post by G4POP »

I suggest that you try Omnirig but select similar radios for testing like 757 etc because the early Yaesu CAT protocols were vary basic and hardly differed from one radio to the next.

Hamlib has often not worked satisfactorily as evidenced by the many posts on this forum and is over complcated
73 Terry G4POP
Novice Class
Posts: 3
Joined: 01 Feb 2023, 17:23

Re: Cat Control not working with Yaesu FT767GX

Post by G6TSJ »

Thanks for the reply Terry,
Unfortunately the 757GX I believe was read only. The 757GXii was more richley featured but on reviewing the ini files not one of the commands are the same as the FT767GX. From what I have read Yaesu seemed to change their CAT control with every rig they produced. :(

Phill G6TSJ
Post Reply