Page 1 of 1

Use of SMB1

Posted: 10 Oct 2018, 15:53
by G4GNX
On my Windows 10 laptop, Log4OM loads files from my network, but when I try to close it down, I get a convoluted message about not being able to connect to the file share because it's not secure.
This share requires the obsolete SMB1 protocol which is unsafe................

Looking at the Microsoft link to resolve this issue, to me the info is obscure and difficult to follow.

Can someone help me to resolve this issue or does this require another new issue of Log4OM?

Re: Use of SMB1

Posted: 10 Oct 2018, 17:20
by IW3HMH
Ciao Alain
is the error produced by Log4OM itself or seems an issue raised by windows?
Basically Log4OM loads an high number of files on start from his config file, all from the config folder, and the database from the user defined folder where it reside.

During normal work, Log4OM write down into the log database itself, so it's pretty strange to have this issue only when closing.

The only activity of data write made at the program closure is the backup of the log in ADIF format (do you have set the SMB folder as backup target?) and the program config file, that stays on the main config folder and is often accessed well before program closure.

Can you send me a screen of the error message? there will be probably something to do at windows level...

Re: Use of SMB1

Posted: 10 Oct 2018, 22:41
by G4GNX
IW3HMH wrote:
10 Oct 2018, 17:20
Ciao Alain
is the error produced by Log4OM itself or seems an issue raised by windows?
Basically Log4OM loads an high number of files on start from his config file, all from the config folder, and the database from the user defined folder where it reside.

During normal work, Log4OM write down into the log database itself, so it's pretty strange to have this issue only when closing.

The only activity of data write made at the program closure is the backup of the log in ADIF format (do you have set the SMB folder as backup target?) and the program config file, that stays on the main config folder and is often accessed well before program closure.

Can you send me a screen of the error message? there will be probably something to do at windows level...
The issue is with the secondary backup to my NAS. If I remove the secondary backup reference, all is OK.
All data from the database is loaded as usual and the primary backup is made on closure.
The main database is in a Dropbox folder which supplies my other PCs which have Log4OM installed.
The problem does appear to be a Windows issue, but right now I'm at a bit of a loss on how to cure it.

Here's a screenshot that you asked for:

Re: Use of SMB1

Posted: 10 Oct 2018, 23:26
by IW3HMH
SAMBA 1 support is not installed on windows 10 by default

[AT YOUR RISK]

Run Powershell command processor in elevated mode (run "powershell" as admin from command line with right click - run as admin)
Type the following command:

get-windowsoptionalfeature -online –featurename smb1protocol

Once SMB has been installed please type the following command to activate it:

enable-windowsoptionalfeature -online –featurename smb1protocol

Once done, press Y and hit enter to restart your computer.

To disable:
disable-windowsoptionalfeature -online –featurename smb1protocol

By the way, try to find a new firmware for your NAS...