TCP Log Command - Grid not written to SQLite log

Yes, sometimes it happens... Please report any bugs here
Post Reply
VK3AMA
Log4OM Beta Team
Posts: 27
Joined: 01 Feb 2013, 22:36

TCP Log Command - Grid not written to SQLite log

Post by VK3AMA » 14 Aug 2013, 22:47

JTAlert sends a correctly formatted adif string via TCP for logging into Log4OM. SQLIte logging is being used. Log4OM 1.14.0

I am trying to debug (for one of my JTAlert users) why a valid grid included in the TCP adif string is not being recorded in the log.

The user has confirmed that the grid is not being recorded in the log and I can confirm this is the case when examining the JTAlert session file which records the data read back from the Log4OM log which shows the grid is missing.

I have personally been unable to reproduce this behavior in my test environment, despite using the exact adif strings (taken from the users log4OMCommunicator_log.txt file). There have been no other reports of this problem, so I am of the opinion that something specific to this users environment is the cause.

Is there a Log4OM setting that could explain this behavior?

Is there additional Log4OM debug data available that may provide more detail?
The log4OMCommunicator_log.txt file shows the log command string received, but not further data about the actual logging event and data. The log4OM_log.txt file provides more detail, but only the Call:, Date:, Time:, Band:, and Mode: are recorded.

de Laurie, VK3AMA

User avatar
IW3HMH
Site Admin
Posts: 2382
Joined: 21 Jan 2013, 14:20
Location: Quarto d'Altino - Venezia (ITA)
Contact:

Re: TCP Log Command - Grid not written to SQLite log

Post by IW3HMH » 15 Aug 2013, 06:46

Hi Laurie, i can add some more logging in the main log (the complete ADIF string parsed) in the next closed beta (probably today)

Everything is passed to Log4OM is parsed and, if valid, used
Checking the code for particular values that could not save the data (incoming version will use ADIF smaller/bigger than the usual 6 chars. How long is the GridSquare in the log?

To avoid overloading the log i will add this log to the "debug mode" (a little more verbose logging mode).
To enable DEBUG MODE open settings -> Settings 1 -> "debug mode" checkbox

I will send you a PM with the download link in a while

73
Daniele IW3HMH
Daniele Pistollato - IW3HMH

User avatar
IW3HMH
Site Admin
Posts: 2382
Joined: 21 Jan 2013, 14:20
Location: Quarto d'Altino - Venezia (ITA)
Contact:

Re: TCP Log Command - Grid not written to SQLite log

Post by IW3HMH » 15 Aug 2013, 07:09

Yep. disregard...
enable DEBUG MODE, you will see each field parsed from the ADIF file in the Log4om main log.
Something it's hard to remember everything there is on the code :D
Daniele Pistollato - IW3HMH

User avatar
G4POP
Moderator
Posts: 5866
Joined: 21 Jan 2013, 14:55
Location: Burnham on Crouch, Essex UK

Re: TCP Log Command - Grid not written to SQLite log

Post by G4POP » 15 Aug 2013, 07:43

Could this be the four digit locator issue Lele?
73 Terry G4POP

VK3AMA
Log4OM Beta Team
Posts: 27
Joined: 01 Feb 2013, 22:36

Re: TCP Log Command - Grid not written to SQLite log

Post by VK3AMA » 15 Aug 2013, 07:55

G4POP wrote:Could this be the four digit locator issue Lele?
If this was directed at me, yes it is a 4 char locator.
But, 4 char locators work for me. Both myself and the user for which the locator logging fail are using 1.14.0

I tried enabling debugging, but the setting is never remembered. Where is the extra debug data written?

These are the adif strings recorded in the log4OMCommunicator_log.txt file that correctly record the Gridsquare for me but fail for the user I am trying to help. I can't see anything wrong with the data.

Code: Select all

<CALL:6>EA7CHS<QSO_DATE:8>20130813<QSO_DATE_OFF:8>20130813<TIME_ON:6>175700<TIME_OFF:6>175700<FREQ:9>14.079638<FREQ_RX:9>14.079638<BAND:3>20m<BAND_RX:3>20m<MODE:3>JT9<RST_SENT:3>-07<RST_RCVD:3>-19<QSL_SENT:1>N<QSL_RCVD:1>N<LOTW_QSL_SENT:1>R<LOTW_QSL_RCVD:1>R<EQSL_QSL_SENT:1>R<EQSL_QSL_RCVD:1>R<GRIDSQUARE:4>IM76<DISTANCE:4>2105<ANT_AZ:3>188<TX_PWR:2>30<LAT:11>N036 30.000<LON:11>W005 00.000<NAME:8>Fernando<QTH:5>Vejer<CQZ:2>14<ITUZ:2>37<CONT:2>EU<DXCC:3>281<COUNTRY:5>Spain<MY_GRIDSQUARE:6>IO95bh<MY_CQ_ZONE:2>14<MY_ITU_ZONE:2>27<STATION_CALLSIGN:5>G6ENY<QSO_COMPLETE:1>Y<A_INDEX:1>6<K_INDEX:1>1<SFI:3>114 <EOR> 

<CALL:5>RW3TP<QSO_DATE:8>20130813<QSO_DATE_OFF:8>20130813<TIME_ON:6>192300<TIME_OFF:6>192400<FREQ:9>14.079155<FREQ_RX:9>14.079155<BAND:3>20m<BAND_RX:3>20m<MODE:5>JT9-1<RST_SENT:3>-05<RST_RCVD:3>-19<QSL_SENT:1>N<QSL_RCVD:1>N<LOTW_QSL_SENT:1>R<LOTW_QSL_RCVD:1>R<EQSL_QSL_SENT:1>R<EQSL_QSL_RCVD:1>R<GRIDSQUARE:4>LO26<DISTANCE:4>2868<ANT_AZ:2>68<TX_PWR:2>30<LAT:11>N056 30.000<LON:11>E045 00.000<COMMENT:6>LO26 E<NAME:6>Victor<QTH:6>Nijniy<CQZ:2>16<ITUZ:2>29<CONT:2>EU<DXCC:2>54<COUNTRY:15>European Russia<MY_GRIDSQUARE:6>IO95bh<MY_CQ_ZONE:2>14<MY_ITU_ZONE:2>27<STATION_CALLSIGN:5>G6ENY<QSO_COMPLETE:1>Y<A_INDEX:1>6<K_INDEX:1>4<SFI:3>114 <EOR>

<CALL:5>RK6AC<QSO_DATE:8>20130813<QSO_DATE_OFF:8>20130813<TIME_ON:6>192900<TIME_OFF:6>192900<FREQ:9>14.079339<FREQ_RX:9>14.079339<BAND:3>20m<BAND_RX:3>20m<MODE:3>JT9<RST_SENT:3>-03<RST_RCVD:3>-22<QSL_SENT:1>N<QSL_RCVD:1>N<LOTW_QSL_SENT:1>R<LOTW_QSL_RCVD:1>R<EQSL_QSL_SENT:1>R<EQSL_QSL_RCVD:1>R<GRIDSQUARE:4>KN95<DISTANCE:4>3043<ANT_AZ:2>94<TX_PWR:2>30<LAT:11>N045 30.000<LON:11>E039 00.000<NAME:8>Lavrenov<QTH:9>Krasnodar<CQZ:2>16<ITUZ:2>29<CONT:2>EU<DXCC:2>54<COUNTRY:15>European Russia<MY_GRIDSQUARE:6>IO95bh<MY_CQ_ZONE:2>14<MY_ITU_ZONE:2>27<STATION_CALLSIGN:5>G6ENY<QSO_COMPLETE:1>Y<A_INDEX:1>6<K_INDEX:1>4<SFI:3>114 <EOR> 

<CALL:5>VK7BO<QSO_DATE:8>20130813<QSO_DATE_OFF:8>20130813<TIME_ON:6>194000<TIME_OFF:6>194000<FREQ:9>14.079888<FREQ_RX:9>14.079888<BAND:3>20m<BAND_RX:3>20m<MODE:3>JT9<RST_SENT:3>-08<RST_RCVD:3>-10<QSL_SENT:1>N<QSL_RCVD:1>N<LOTW_QSL_SENT:1>R<LOTW_QSL_RCVD:1>R<EQSL_QSL_SENT:1>R<EQSL_QSL_RCVD:1>R<GRIDSQUARE:4>QE38<DISTANCE:5>17287<ANT_AZ:2>69<TX_PWR:2>30<LAT:11>S041 30.000<LON:11>E147 00.000<COMMENT:33>QSL: QSL ONLY VIA EA7FTR TNX QE38<NAME:4>Alan<QTH:9>Riverside<CQZ:2>30<ITUZ:2>59<CONT:2>OC<DXCC:3>150<COUNTRY:9>Australia<MY_GRIDSQUARE:6>IO95bh<MY_CQ_ZONE:2>14<MY_ITU_ZONE:2>27<STATION_CALLSIGN:5>G6ENY<QSO_COMPLETE:1>Y<A_INDEX:1>6<K_INDEX:1>4<SFI:3>114 <EOR> 
2013-08-13 20:52:22.9704 INFO:       Log4OmCommunicator.BL.TCPManagement: Incoming QSO from TCP Connection (ADD) 
2013-08-13 20:52:22.9714 INFO:       Log4OMCommunicator:FormMain: Incoming TCP QSO <CALL:6>IN3TJO<QSO_DATE:8>20130813<QSO_DATE_OFF:8>20130813<TIME_ON:6>195200<TIME_OFF:6>195200<FREQ:9>14.077171<FREQ_RX:9>14.077171<BAND:3>20m<BAND_RX:3>20m<MODE:4>JT65<RST_SENT:3>-01<RST_RCVD:3>-07<QSL_SENT:1>N<QSL_RCVD:1>N<LOTW_QSL_SENT:1>R<LOTW_QSL_RCVD:1>R<EQSL_QSL_SENT:1>R<EQSL_QSL_RCVD:1>R<GRIDSQUARE:4>JN55<DISTANCE:4>1418<ANT_AZ:3>135<TX_PWR:2>30<LAT:11>N045 30.000<LON:11>E011 00.000<COMMENT:1>E<NAME:9>Gianpaolo<QTH:4>Arco<CQZ:2>15<ITUZ:2>28<CONT:2>EU<DXCC:3>248<COUNTRY:5>Italy<MY_GRIDSQUARE:6>IO95bh<MY_CQ_ZONE:2>14<MY_ITU_ZONE:2>27<STATION_CALLSIGN:5>G6ENY<QSO_COMPLETE:1>Y<A_INDEX:1>6<K_INDEX:1>4<SFI:3>114 <EOR> 
de Laurie, VK3AMA

User avatar
G4POP
Moderator
Posts: 5866
Joined: 21 Jan 2013, 14:55
Location: Burnham on Crouch, Essex UK

Re: TCP Log Command - Grid not written to SQLite log

Post by G4POP » 15 Aug 2013, 08:19

Hi Laurie,
My comment was about a bug we had in the last public release where 4 digit locators were showing during QSO entry but not being saved to the log.

This issue has been fixed in the latest beta that the team are currently testing
73 Terry G4POP

VK3AMA
Log4OM Beta Team
Posts: 27
Joined: 01 Feb 2013, 22:36

Re: TCP Log Command - Grid not written to SQLite log

Post by VK3AMA » 20 Aug 2013, 05:37

OK Terry,

The 4 char grid bug may be the root cause. Why it works for me yet not the user I am helping when we both are using the latest public release is the big unknown.

I'll wait until the next public release before pursuing this any further.

de Laurie, VK3AMA

User avatar
IW3HMH
Site Admin
Posts: 2382
Joined: 21 Jan 2013, 14:20
Location: Quarto d'Altino - Venezia (ITA)
Contact:

Re: TCP Log Command - Grid not written to SQLite log

Post by IW3HMH » 20 Aug 2013, 10:16

We released Saturday a release that should fix this issue.
Please let me know if works for your user.

73 Daniele IW3HMH
Daniele Pistollato - IW3HMH

VK3AMA
Log4OM Beta Team
Posts: 27
Joined: 01 Feb 2013, 22:36

SOLVED - TCP Log Command - Grid not written to SQLite log

Post by VK3AMA » 23 Aug 2013, 03:03

I have been advised that the new release does solve the Grid logging problem.

Thanks
de Laurie, VK3AMA

Post Reply