PstRotator, Log4OM not communicating

Need help? - Post here and we will find a solution for you.
oe3ide
Advanced Class
Posts: 34
Joined: 09 Feb 2017, 08:33

Re: PstRotator, Log4OM not communicating

Post by oe3ide » 10 May 2019, 18:55

the only difference is that I cannot find where you entered the IP address you mentioned (other than Communication/TCP Client, whereas I use RS232/TCP server to communicate with the AlfaSpid controller). Also, where did you select ‘Automatic positions reporting’?
In PSTRotator Menue "Comm" - "UDP Control Setup"
Attachments
udp.jpg
udp.jpg (44.12 KiB) Viewed 590 times

G4IUA
Novice Class
Posts: 29
Joined: 15 Apr 2014, 19:20

Re: PstRotator, Log4OM not communicating

Post by G4IUA » 10 May 2019, 19:53

Switched off Kaspersky Antivirus software. Ditto Windows Defender.

I've attached the Communicator logfile, complete with error messages (which are all beyond me...).

Jeff
Attachments
Log Comm 10-5-19.JPG
Log Comm 10-5-19.JPG (167.05 KiB) Viewed 590 times

User avatar
G4POP
Moderator
Posts: 5564
Joined: 21 Jan 2013, 14:55
Location: Burnham on Crouch, Essex UK

Re: PstRotator, Log4OM not communicating

Post by G4POP » 10 May 2019, 22:11

Have you set up the Log4OM communicator for PSTRotator as below?

Capture.JPG
Capture.JPG (39.76 KiB) Viewed 584 times


This is how it works....

1. Log4OM sends the message to set rotator to the Log4OM communicator


2. The Log4OM Communicator hen forwards that message to PSTRotator


3. PSTRotator activates your rotator


The message is clearly being sent to the communicator and onward to PSTRotator, we can see those actions inn the log files that you posted


So either you have not set up the communicator as above, or there is something perhaps blocking the message between the communicator and PSTRotator.


BTW the error messages re Growl, which is used for sending DX Spot alerts, is because the Growl server no longer functions so just disregard them they are not associated with the rotator control.

If you cant resolve this by setting up the communicator correctly please generate a support request and email it to me. The instructions about sending a support request are here http://www.log4om.com/log4om-support/
73 Terry G4POP

G4IUA
Novice Class
Posts: 29
Joined: 15 Apr 2014, 19:20

Re: PstRotator, Log4OM not communicating

Post by G4IUA » 10 May 2019, 22:18

Thanks Terry. The Communication setup is exactly as you've shown and I'm satisfied that part has always been correct. At this stage I think it best I send thru the support request as you suggested.

I'm grateful for the support shown by all who responded to my post but I think I've now exhausted all the suggestions.

Jeff - G4IUA

User avatar
G4POP
Moderator
Posts: 5564
Joined: 21 Jan 2013, 14:55
Location: Burnham on Crouch, Essex UK

Re: PstRotator, Log4OM not communicating

Post by G4POP » 11 May 2019, 07:38

Jeff,
Dont forget to set Trace mode and then try using the rotator control before generating the support request

Email me at my email address shown on QRZ
73 Terry G4POP

G4IUA
Novice Class
Posts: 29
Joined: 15 Apr 2014, 19:20

Re: PstRotator, Log4OM not communicating

Post by G4IUA » 16 May 2019, 23:04

In desperation I uninstalled the Kaspersky antivirus software and it suddenly started to work! I then reinstalled it and it still works perfectly, so although I am a loss to know exactly why this is the case I’m happy to accept that all is now well. Before uninstalling Kaspersky I disabled it and assumed that would prevent it from blocking the flow of data from Log4OM’s Communicator and PstRotator. Clearly this didn’t work as I expected.

Thanks for all the suggestions, and especially to Terry for his support. The TeamViewer session confirmed that neither Log4OM nor PstRotator were at fault so it had to be something in between them…and so it was.

Great to have everything working well: entering callsigns into Log4OM, cluster, Park, etc. all work perfectly. Great combination of software.

Jeff – G4IUA

Post Reply