WSJTX 1.6 and Log4om

Regarding connecting to external program's.
Post Reply
EI2GLB
Advanced Class
Posts: 98
Joined: 21 Jan 2013, 22:19

WSJTX 1.6 and Log4om

Post by EI2GLB » 12 Feb 2016, 08:14

Hi All

I have downloaded wsjtx 1.6 and it works fine until i open log4om and then it looses cat control of my rig,

I have the latest version of omnirig, I have both programms running as an administrator,

any ideas whats going on,

Thanks
Trevor

User avatar
G4POP
Log4OM Alpha Team
Posts: 6598
Joined: 21 Jan 2013, 14:55
Location: Burnham on Crouch, Essex UK

Re: WSJTX 1.6 and Log4om

Post by G4POP » 12 Feb 2016, 10:18

EI2GLB wrote:Hi All

I have downloaded wsjtx 1.6 and it works fine until i open log4om and then it looses cat control of my rig,

I have the latest version of omnirig, I have both programms running as an administrator,

any ideas whats going on,

Thanks
Trevor

Are you also employing JTAlert?

Have you set up as described on pages 182-183 of the user guide?
73 Terry G4POP

User avatar
DF5WW
Log4OM Alpha Team
Posts: 1314
Joined: 02 May 2013, 09:49
Location: Kraam, Rhineland Palatinate, Germany

Re: WSJTX 1.6 and Log4om

Post by DF5WW » 15 Feb 2016, 18:30

Hi Daniele,

i think that´s not a Log4OM problem nor a problem with WSJT-X or JT-Alert. Omnirig can handle more than one software on a hardware serial com but it looks like that it not works with virtual com ports ....

I have the same problem that i have to set the band manually when i work with WSJT-X and Log4OM .... My CAT/Digi Interface is a SB-1000 by CG antennas and it works with a virtual COM 3. If Omnirig is connected to my old IC-735 via this modem WSJT-X can´t grab the frequency from Omnirig ...

Bad thing but is as it is .... ;) ;)

B.t.w. logging via JT-Alert works great. Good Job of VK3AMA :!: :!:
73´s .. Juergen ... ALT-512 SDR (10W) , 2 x 6,5 mtr. indoor wire at CG-3000 autotuner ...

EI2GLB
Advanced Class
Posts: 98
Joined: 21 Jan 2013, 22:19

Re: WSJTX 1.6 and Log4om

Post by EI2GLB » 15 Feb 2016, 23:28

Hi Terry

I found in another post that I need to select omnirig 1 and not my actual rig in WSJT-X


Thanks
Trevor

User avatar
IW3HMH
Site Admin
Posts: 2575
Joined: 21 Jan 2013, 14:20
Location: Quarto d'Altino - Venezia (ITA)
Contact:

Re: WSJTX 1.6 and Log4om

Post by IW3HMH » 17 Feb 2016, 16:07

A possible solution is to implement a wrapper before omnirig that is able to accept multiple connections to be forwarded to Omnirig/Hamlib/Flrig
I'm thinking about that in Log4OM V2...
Daniele Pistollato - IW3HMH

Post Reply