Page 1 of 1

Fldigi 4.018 Log4OM connection issue

Posted: 24 Jan 2019, 10:47
by nigelspear
This is one of those annoying software issues - in that something that was working is now not! The question is "OK so what changed?" As far as I know I have changed nothing other have been playing with some of the audio settings in Fldigi - which I cant see could affect its ability to talk to LOG4OM.

My setup is:

Fldigi setup to use xmlrpc
Capture1.PNG
Capture1.PNG (15.32 KiB) Viewed 3332 times
LOG4OM
Capture3.PNG
Capture3.PNG (16.51 KiB) Viewed 3332 times
Capture4.PNG
Capture4.PNG (61.49 KiB) Viewed 3332 times
Fldig, Log4OM are running as administrator
The windows firewall is disabled
There is no additional security software on this machine (other than Windows Defender)
Although it worked before - only changes to the frequency from my rig got reflected correctly. Changing the frequency on Flidigi never got reflected

Re: Fldigi 4.018 Log4OM connection issue

Posted: 24 Jan 2019, 11:09
by DF5WW
Hello OM,

did you have hit the "Initialize"-Button in the XMLRPC setting at the first start of
Fldigi as described in the Fldigi setup in the manual ? Did you start Fldigi first before
you start Log4OM like described in the manual too ?

Last but not least, are all the lights are green in the Log4OM communicator when
Fldigi and Log4OM are running ?

FLdigi.png
FLdigi.png (49.15 KiB) Viewed 3330 times

If not all green you can check them manually .....

By the way, frequency changes in Fldigi not resulting in changes in Log4OM and the Transceiver.

Re: Fldigi 4.018 Log4OM connection issue

Posted: 24 Jan 2019, 12:01
by nigelspear
Hi

Yes I have hit the initialise button in the XMLRPC setting.
The connection buttons to and from FLDIGI are both red
If I manual push the start buttons - they both go green for a few seconds but then return to red. If I switch to the log tab, I see it trying to connect but keep getting the "unable to connect to remote server" message (as in the log screen capture above"
Im starting FLDIGI before LOG4OM

Thanks for the suggestions!

Re: Fldigi 4.018 Log4OM connection issue

Posted: 24 Jan 2019, 14:20
by G4POP
Did you recently update Fldigi?

Re: Fldigi 4.018 Log4OM connection issue

Posted: 24 Jan 2019, 14:45
by nigelspear
Hi

No this is the version I have been running for a month or so

Re: Fldigi 4.018 Log4OM connection issue

Posted: 24 Jan 2019, 15:07
by G4POP
For some reason the FLDigi server is not available, according to the logfile you posted here.

So check that there is no other CAT control enabled in FLdigi like rigcat, Hamlib or flrig

Try a fresh install of FLdigi

Check your firewall or virus software is not blocking the connection

If none of the above fail to resolve the issue ask on the FLDigi forum about reasons for the server not to function

incidentally I have FLDigi Version 4.0.18 running perfectly with Log4OM version 1.36

Re: Fldigi 4.018 Log4OM connection issue

Posted: 24 Jan 2019, 15:22
by G4POP
also are you sure that you have changed nothing here?

The lock box should be checked I unchecked it for clarity of image

Untitled.jpg
Untitled.jpg (99.54 KiB) Viewed 3311 times

Re: Fldigi 4.018 Log4OM connection issue

Posted: 25 Jan 2019, 09:44
by nigelspear
Thanks for all the suggestions

Fldigi configuration looks fine
Capture.PNG
Capture.PNG (25.68 KiB) Viewed 3295 times
All of the other tabs in rig control are not selected (FLrig,RigCat,Hamlib and Hardware PTT)

Firewall - there is no firewall running on the small windows box im using for LOG4OM and Fldigi

I have tried reinstalling Fldigi.
However although I de-installed using programs and features, this must leave something behind as my settings were retained when I re installed (ie operator info, macros etc)
Are there additional steps to completely eradicate Fldigi when you de-install?

Re: Fldigi 4.018 Log4OM connection issue

Posted: 25 Jan 2019, 09:50
by G4POP
No it's NOT the same

You have changed the XML port number, change it back to match the screen shot I posted 7362

Don't forget to save the configuration from the Fldigi file menu as well as the window above

Re: Fldigi 4.018 Log4OM connection issue

Posted: 25 Jan 2019, 11:09
by nigelspear
SOLVED!

You are a star Terry
Its always the way, you cant see something for the sake of looking!
No idea how that got changed as I have never been into that screen before, and I would have assumed locked means it cant be change.
Nevertheless, that immediately fixed the problem

Thanks for all the community help