Help wanted with intergrating MRP40 ADIF log

Regarding connecting to external program's.
Post Reply
GW0ANA
Novice Class
Posts: 17
Joined: 30 Jun 2019, 14:16

Help wanted with intergrating MRP40 ADIF log

Post by GW0ANA » 17 Sep 2019, 15:54

Dear Log4OM`ers ,

Please would you help this octogenarian get his head around a big problem I have "How I can get Log4OM" to input in real time the ADIF log from the CW program MRP40. It runs WSJT-X and puts my FT8 contacts in the log including frequency and signal reports perfectly. But I am having big trouble trying to get Log4OM to read the ADIF mini log and put it into LOg4OM. Any help and guidance would be very much appreciated.
Kind regards
Glyn GW0ANA

User avatar
G4POP
Log4OM Alpha Team
Posts: 7462
Joined: 21 Jan 2013, 14:55
Location: Burnham on Crouch, Essex UK

Re: Help wanted with intergrating MRP40 ADIF log

Post by G4POP » 17 Sep 2019, 19:24

First the usual questions

1. Are you running Log4om with administrator privileges as detailed in our user guide page 9?

2. Are you running MRP40 in the same manner?

3. Did you set the communicator inbound menu to check the MRP40 adif file using the correct path to the file?

4. Is the communicator running in the background ok?

Please also supply the version number of log4om and what windows opperating system you use
73 Terry G4POP

GW0ANA
Novice Class
Posts: 17
Joined: 30 Jun 2019, 14:16

Re: Help wanted with intergrating MRP40 ADIF log

Post by GW0ANA » 18 Sep 2019, 16:51

Hello Terry,
I thank you for your kind reply. To answer your questions?
I am running both Log4OM & MRP40 in administrator privileges on.

I checked the path, it was difficult for me to find it, as it is listed as the following.
C:/ Program files/X86/Ham radio Software/ MRP40 Morse/ Logfiles/contact log/ minilog.adif (File ticked in communicator and saved)

LOG4OM version 1.39
Windows 7 Pro
64 Bit Operating
8 Gig Ram 7 free
CPU E31225 @ 3.1 GHz

I worked an SM on 17 meters CW but it failed to log it in Log4OM? I had to do it manually.
Thank you Terry in advance for any further suggestions. 73 Glyn GW0ANA

User avatar
G4POP
Log4OM Alpha Team
Posts: 7462
Joined: 21 Jan 2013, 14:55
Location: Burnham on Crouch, Essex UK

Re: Help wanted with intergrating MRP40 ADIF log

Post by G4POP » 18 Sep 2019, 21:44

Hi Glyn,
I set up to log from MRP40 tonight and its all working fine here for me.

The path I used was C:\Program Files (x86)\HamRadioSoftware\MRP40 Morse Decoder V66\LogFiles\Contact Log\MiniLogBook.ADIF

I then logged two QSO's in MRP40 and both appeared in Log4OM just fine.

Dont forget that you must get the capital letters correct because its case sensitive.


I suggest that you set the starting possition to zero and make sure the MRP40 adif file just contains the missing QSO's to avoid duplicates, my one shows 656 after importing 2 QSO's

Here is my communicator window

Untitled.jpg
Untitled.jpg (58.55 KiB) Viewed 1672 times
73 Terry G4POP

GW0ANA
Novice Class
Posts: 17
Joined: 30 Jun 2019, 14:16

Re: Help wanted with intergrating MRP40 ADIF log

Post by GW0ANA » 19 Sep 2019, 18:44

Hello Terry,
My thanks to you we are nearly there . There are a couple of call sign glitches. It read HB0 & 3Z50, and logged it HB* as a symbol like a diamond, and not HBzero the call sign of Liechtenstein it was the same with the 3Z50 special event Poland again no Zero just a diamond like symbol instead of the Zero.

One other thing it does not input the country I guess the strange symbol instead of a Zero confuses Log4OM with what country to log. hi.

My thanks Terry I will have to check each QSO to see what is happening.
When I took your advice on setting the file to zero it would not allow me it just inserted ) so I put in 2 then used down arrows to get to zero.

Now when I checked back at the Minilog file the setting shows a start number now of 628. I have left it hi.

So as I said with your help we are nearly there. I will just keep an eye on it.

My version is 4.064
73 Glyn GW0ANA

Post Reply