Autostart launch of WSJT-x and JTAlert

Post Reply
IW0GS
Novice Class
Posts: 4
Joined: 27 May 2020, 16:41

Autostart launch of WSJT-x and JTAlert

Post by IW0GS » 02 Jun 2020, 07:56

Good morning everybody,
Have a problem with autostart, infact I would like to launch WSJT-X and JTAlert togheter with LOG4OM but if I do that the JTAlert ask me everytime if it must be used with WSJT-x or with JTDX despite I have configured it to operate with WSJT-X at the istallation.
If I launcu the WSJT-X manualy and after run JTAlert , it works well without ask and run in WSJT-X mode.
I guess tha could be a timing problem , is it possible to insert a delay in the autostart and wait few seconds after the WSJT-X launch before the JTAlert execution? Wath do you think ?
many thanks in advance and 73

User avatar
KI5IO
Log4OM Alpha Team
Posts: 588
Joined: 16 Aug 2015, 16:30

Re: Autostart launch of WSJT-x and JTAlert

Post by KI5IO » 02 Jun 2020, 10:50

IW0GS wrote:
02 Jun 2020, 07:56
Good morning everybody,
Have a problem with autostart, infact I would like to launch WSJT-X and JTAlert togheter with LOG4OM but if I do that the JTAlert ask me everytime if it must be used with WSJT-x or with JTDX despite I have configured it to operate with WSJT-X at the istallation.
If I launcu the WSJT-X manualy and after run JTAlert , it works well without ask and run in WSJT-X mode.
I guess tha could be a timing problem , is it possible to insert a delay in the autostart and wait few seconds after the WSJT-X launch before the JTAlert execution? Wath do you think ?
many thanks in advance and 73
OM,

Doesn't JTAlert provide two separate start-up icons/routines with their installation package? One for WSJTx and one for JTDX?

I know I have two separate icons on my desktop. One is for JTDX and one is for WSJTx.

Maybe you are selecting the wrong one in your code?
73 - Nolan Kienitz - KI5IO
Plano, TX

User avatar
DF5WW
Log4OM Alpha Team
Posts: 1459
Joined: 02 May 2013, 09:49
Location: Kraam, Rhineland Palatinate, Germany

Re: Autostart launch of WSJT-x and JTAlert

Post by DF5WW » 02 Jun 2020, 13:28

You´re right Nolan but Log4OM autostart facility can´t handle the icons. I´ve tried to use the
parameters field in the autostart with /jtdx or /wsjtx and that works. I have
the error message too but it goes away if JTDXis completely loaded and JTalert is running
without problems.
73´s .. Juergen ... ALT-512 SDR (10W) , 50 m random wire at CG-3000 autotuner ...

IW0GS
Novice Class
Posts: 4
Joined: 27 May 2020, 16:41

Re: Autostart launch of WSJT-x and JTAlert

Post by IW0GS » 02 Jun 2020, 14:05

Dear friend,
I have specified that I have selected the JTAlert for WSJT-X in the LOG4OM Autostart.
Furthermore I mentioned that if I launch the JTAlert manualy, after the WSJT-X is installed, it start without asking for wich program shoud run.
Any other sugestion?
Thanks
Pasquale IW0GS

User avatar
DF5WW
Log4OM Alpha Team
Posts: 1459
Joined: 02 May 2013, 09:49
Location: Kraam, Rhineland Palatinate, Germany

Re: Autostart launch of WSJT-x and JTAlert

Post by DF5WW » 02 Jun 2020, 14:33

No other suggestions possible. There is no delay possible at the present time. As i mentioned,
i have settet up to start JTDX and JTalert in Autostart. After Log4OM was loaded it starts JTDX
and JTalert. The popup comes up that JTalert can only start if JTDX is running. The popup leaves
if JTDX is loaded and all programs running fine.

1.png
1.png (35.84 KiB) Viewed 165 times
73´s .. Juergen ... ALT-512 SDR (10W) , 50 m random wire at CG-3000 autotuner ...

User avatar
KI5IO
Log4OM Alpha Team
Posts: 588
Joined: 16 Aug 2015, 16:30

Re: Autostart launch of WSJT-x and JTAlert

Post by KI5IO » 02 Jun 2020, 16:01

Looks like everything is in order to run ... except for a "delay" (of sorts) before JTAlert gets kicked off to run and load.

If I run JTDX or WSJTx and JTAlert (no Log4OM V2) I have to first start JTDX and WSJTx. Once they are running I can start JTAlert. JTAlert hangs/waits for WSJTx or JTDX.

So ... Juergen ... we need to see about a Mantis item to add an option for delays with such parameters. That way we can add it to the "to do" list for a future release of Log4OM V2.
73 - Nolan Kienitz - KI5IO
Plano, TX

User avatar
DF5WW
Log4OM Alpha Team
Posts: 1459
Joined: 02 May 2013, 09:49
Location: Kraam, Rhineland Palatinate, Germany

Re: Autostart launch of WSJT-x and JTAlert

Post by DF5WW » 03 Jun 2020, 04:05

It´s on Mantis now. Have to go to work ... bye. ;) ;)
73´s .. Juergen ... ALT-512 SDR (10W) , 50 m random wire at CG-3000 autotuner ...

Post Reply