Log4OM 2 will not connect to WSJT-X

Post Reply
GW0ANA
Novice Class
Posts: 14
Joined: 30 Jun 2019, 14:16

Log4OM 2 will not connect to WSJT-X

Post by GW0ANA » 30 Jul 2020, 15:42

Hello I have spent weeks trying to get it to work but its beat me. I have read so many files & watched so much YouTube Vids. But I am going around in circles. On the version 1 of log4om all worked a treat.
I can get Log4OM2 to connect to my IC-7300 as per screen shot on its own. Also I can run WSJT-X on its own and have QSO`s. But I cannot get them to talk to each other.

I get a rig control error notice.
I have attached screen shots.

My Computer is Windows 7
Capture 2.JPG
Capture 2.JPG (165.66 KiB) Viewed 148 times
https://forum.log4om.com/download/file. ... ew&id=3886

https://forum.log4om.com/download/file. ... ew&id=3888
Attachments
Capture 4.JPG
Capture 4.JPG (27.12 KiB) Viewed 148 times
Capture 3.JPG
Capture 3.JPG (195.73 KiB) Viewed 148 times

User avatar
DF5WW
Log4OM Alpha Team
Posts: 1491
Joined: 02 May 2013, 09:49
Location: Kraam, Rhineland Palatinate, Germany

Re: Log4OM 2 will not connect to WSJT-X

Post by DF5WW » 30 Jul 2020, 15:52

First of all: You refer to Log4OM V2 so next time please use the V2 section of the forum. It´s the
upper part.

Have you run all softwares like Log4OM V2, WSJT-X and Omnirig running as administrator ? If not only
one program can connect to CAT via Omnirig. Log4OM starting Omnirig and getting CAT control, if you now
will let have WSJT-X also having CAT control it can be connect to Omnirig that have an instance with V2.

Only with administrativ privileges in all softwares that are used for CAT Omnirig can use it´s multithreading.

So please check:

Omnirig (run as administrator ?)
Log4OM V2 (run as administrator ?)
WSJT-X (run as administrator ?)
73´s .. Juergen ... ALT-512 SDR (10W) , 50 m random wire at CG-3000 autotuner ...

User avatar
G4POP
Log4OM Alpha Team
Posts: 7282
Joined: 21 Jan 2013, 14:55
Location: Burnham on Crouch, Essex UK

Re: Log4OM 2 will not connect to WSJT-X

Post by G4POP » 31 Jul 2020, 06:17

Change WSJT radio setting to Omnirig rig1, not the Icom selection as in your screen shot

Ensure that all software that is using Omnirig is installed to 'Run as an administrator'
73 Terry G4POP

Post Reply